apktool使用过程中遇到的错误
apktool使用过程中遇到的错误
独鸣在彼岸 发表于2年前
apktool使用过程中遇到的错误
  • 发表于 2年前
  • 阅读 190
  • 收藏 1
  • 点赞 1
  • 评论 0

标题:腾讯云 新注册用户域名抢购1元起>>>   

摘要: 错误记录
1. Destination directory (D:\dayly\apktool1.5.2\crackme0201) already exists. Use -f switch if you want to overwrite it.

说明crackme0201文件夹已经存在,删除这个文件夹后问题就好了。

2. Exception in thread "main" brut.androlib.AndrolibException: Could not decode ars c file

apktool的版本太低,导致反编译时出错。从 下载地址 下载最新的jar,比如现在最新的版本 apktool_2.0.3.jar之后,更名为apktool.jar,重新执行反编译就不会出错了。

3. Exception in thread "main" brut.androlib.err.UndefinedResObject: resource spec: 0x01010479

删除文件夹C:\Users\用户\apktool\framework下的内容,如果你使用的是XP系统且没有在C盘下找到用户目录,那么这个文件夹可能放置的位置: C:\Documents and Settings\%current user%\apktool\framework。

4.Exception in thread "main" brut.androlib.AndrolibException: brut.directory.PathNotExist: apktool.yml

这极有可能是因为你的路径没有写对,比如我这里使用b命令重新打包apk时就写错了,正确的写法应当是apktool b showjava sign.apk, b命令后跟的是反编译时得到的文件夹,然后才是需要得到的apk的名称。

标签: apktool 反编译
共有 人打赏支持
粉丝 4
博文 188
码字总数 35784
×
独鸣在彼岸
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: