文档章节

Android 中会出现的问题:This Android SDK requires Andro...

 才沐木
发布于 2012/07/17 10:05
字数 279
阅读 235
收藏 0

windows 下面安装Android虚拟机,有时候选择更新SDK后,在Eclipse preference里指向android_sdk_windows_x86时。会出现诸如This AndroidSDK requires  Android Developer Toolkit version 10.0.0or above这样的提示,而且虚拟机无法打开的情况,这是由于选择更新后,在android_sdk_windows_x86/tools/lib下的 plugin.pro文件里被变更为

# begin plugin.prop
plugin.version=10.0.0
# end plugin.prop

Eclipse 在查看该文件时,看到plugin.version=10.0.0,就认为当前的sdk需要10.00版本以上的插件,但是当前 的插件还未来得及更新到10.0.0版本,但我们只想用以前旧的插件,最简单的方法就是将plugin.version的版本信息改为旧版本的版本号,诸 如9.0.0.当前SDK的版本已经更新至14.0.0,我在误点更新之后,提示需要更新Android Developer Toolkit到14.0.0.0版本以上,而以前下下来的低版本的AndroidDeveloper Toolkit 却无法使用,查到后才发现是该文件的问题,修改plugin.version=12.0.0(我的旧的Android Developer Toolkit )保存,再重启一下Eclipse就能用以前旧的avd了

© 著作权归作者所有

粉丝 0
博文 3
码字总数 876
作品 0
深圳
程序员
私信 提问
android 中adt ,sdk,api的对应关系

ADT(Android Development Tools):目前Android开发所用的开发工具是Eclipse,在Eclipse编译IDE环境中,安装ADT,为Android开发提供开发工具的升级或者变更,简单理解为在Eclipse下开发工具的...

happyliferao
2015/06/26
0
1
Android requires compiler compliance level 5.0 ...

重装操作系统后,要重新配置Android开发环境。配置成功后,添加原本项目时却出现了错误! Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Andro......

垂盆草
2012/03/05
0
0
Android的SDK与ADT不匹配问题

win7/xp 下面安装Android虚拟机,更新SDK后,在Eclipse preference里指向android-sdk-windows时。 出现 : This Android SDK requires Android Developer Toolkit version 17.0.0 or above.......

echocao
2013/04/22
0
0
Android requires compiler compliance level 5.0 ...

重装操作系统后,要重新配置Android开发环境。配置成功后,添加原本项目时却出现了错误! Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Andro......

gavin_jin
2012/04/14
0
0
Android开发错误信息与解决方案汇总

【错误信息】 [2011-01-19 16:39:10 - ApiDemos] WARNING: Application does not specify an API level requirement! [2011-01-19 16:39:10 - ApiDemos] Device API version is 8 (Android 2......

小克898
2012/10/31
0
0

没有更多内容

加载失败,请刷新页面

加载更多

GMTC2019|闲鱼-基于Flutter的架构演进与创新

2012年应届毕业加入阿里巴巴,主导了闲鱼基于Flutter的新混合架构,同时推进了Flutter在闲鱼各业务线的落地。未来将持续关注终端技术的演变及趋势 Flutter的优势与挑战 Flutter是Google开源的...

阿里云官方博客
10分钟前
0
0
ubuntu安装软件 报错:下列软件包有未满足的依赖关系

ubuntu安装软件,一直出现以下错误,还纳闷为毛都和 lksctp-tools 有关,上网差发现可能是 lksctp-tools安装错误。 pvc@pvc-Vostro-3650:~$ sudo apt-get install libnet1-dev 正在读取软件包...

琴麻岛
12分钟前
0
0
GMTC2019|闲鱼-基于Flutter的架构演进与创新

2012年应届毕业加入阿里巴巴,主导了闲鱼基于Flutter的新混合架构,同时推进了Flutter在闲鱼各业务线的落地。未来将持续关注终端技术的演变及趋势 Flutter的优势与挑战 Flutter是Google开源的...

zhaowei121
13分钟前
0
0
一段话系列-在抢购秒杀中,如何解决Redis读写分离带来的,主从同步延迟问题?

在抢购秒杀中,我们将数据缓存在Redis中,Redis我们为了提高QPS,使用了读写分离的架构,随之而来的便是主从同步延迟问题;在这里,我认为针对于主从同步延迟问题是不可避免的,我给出的解决...

EasyProgramming
14分钟前
0
0
linux sudo java : command not found

运行sudo java -version报错 [admin@localhost xxx]$ sudo java -version sudo: java: command not found 原因: 当使用sudo去执行一个程序时,处于安全的考虑,这个程序将在一个新的、最小化...

朝如青丝暮成雪
18分钟前
1
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部