文档章节

Ruby安装

起个昵称好难啊
 起个昵称好难啊
发布于 2016/11/11 14:30
字数 529
阅读 2
收藏 0

步骤0 - 安装系统需要的包

 

  # For Mac 
  # 先安装 [Xcode](http://developer.apple.com/xcode/) 开发工具,它将帮你安装好 Unix 环境需要的开发包

步骤1 - 安装 RVM

 

RVM 是干什么的这里就不解释了,后面你将会慢慢搞明白。

    $ curl -L https://get.rvm.io | bash -s stable

期间可能会问你sudo管理员密码,以及自动通过homebrew安装依赖包,等待一段时间后就可以成功安装好 RVM。

然后,载入 RVM 环境(新开 Termal 就不用这么做了,会自动重新载入的)

    $ source ~/.rvm/scripts/rvm

检查一下是否安装正确

    $ rvm -v
    rvm 1.22.17 (stable) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]

步骤2 - 用 RVM 安装 Ruby 环境

  

列出已知的ruby版本

   $ rvm list known

 

可以选择现有的rvm版本来进行安装(下面以rvm 2.0.0版本的安装为例)

 

    $ rvm install 2.0.0

同样继续等待漫长的下载,编译过程,完成以后,Ruby, Ruby Gems 就安装好了。

另附:

查询已经安装的ruby

  $ rvm list

卸载一个已安装版本 

      $ rvm remove 1.9.2

步骤3 - 设置 Ruby 版本

 

RVM 装好以后,需要执行下面的命令将指定版本的 Ruby 设置为系统默认版本

    $ rvm 2.0.0 --default

同样,也可以用其他版本号,前提是你有用 rvm install 安装过那个版本

这个时候你可以测试是否正确

    $ ruby -v
    ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-darwin13.0.0]

    $ gem -v
    2.1.6

这有可能是因为Ruby的默认源使用的是cocoapods.org,国内访问这个网址有时候会有问题,网上的一种解决方案是将远替换成淘宝的,替换方式如下:
     $gem source -r https://rubygems.org/
    $ gem source -a https://ruby.taobao.org

 要想验证是否替换成功了,可以执行:

    $ gem sources -l  

正常的输出结果:

      CURRENT SOURCES            

      http://ruby.taobao.org/            

到这里就已经把Ruby环境成功的安装到了Mac OS X上,接下来就可以进行相应的开发使用了。

 

注意:如果是为了安装cocoapods而安装ruby,需安装2.2.2版本以上的ruby

本文转载自:

起个昵称好难啊
粉丝 5
博文 31
码字总数 9268
作品 0
朝阳
私信 提问
red hat linux 安装 ruby on rails

一、安装ruby 1、 下载资源 从Ruby官网下载ruby的源代码:https://www.ruby-lang.org/en/downloads/ 如下载2.1.1版本 2、解压包 ruby-2.1.1.tar.gz tar xvfz ruby-2.1.1.tar.gz 3、编译 cd r...

edmBest
2014/04/26
0
0
安装RUBY ON RAILS

本指南是这篇文章《Ubuntu, Ruby, RVM, Rails, and You》的中文翻译,它将指导你在Unbuntu安装Ruby 1.9.3,RVM和Rails 3.1.3。以下步骤已在ubuntu 11.04下验证通过,吼吼! 如果你需要在产品...

alex.wu
2012/03/18
0
2
Ruby 版本管理工具--ruby-build

ruby-build 是一个 rbenv 插件,它提供了一个 rbenv install 命令来在类 UNIX 系统上编译和安装不同版本的 Ruby。 你还可以在需要精确控制 Ruby 版本安装的环境中使用不带 rbenv 的 ruby-bui...

匿名
2017/03/02
221
0
2018.12月解决cocoapods问题记录

使用cocopod报错, • 系统:macOS Mojave10.14 >>很久没用替换先更换Ruby源,国内镜像源 taobao 源 已经停止维护了(由于国内被墙)所以要把源切换至ruby-china地址:(https://gems.ruby-china...

秦无炎
2018/12/18
0
0
redis-cluster创建步骤

官方提供了脚本创建集群的工具,我们参照官方的指导进行创建集群以我本测试环境为例: /usr/local/soft/redis-cluster/redis-3.2.1/utils/create-cluster 进入脚本目录后执行集群创建失败,如...

nj-zhangmq
2016/07/22
79
0

没有更多内容

加载失败,请刷新页面

加载更多

Command模式

https://www.cnblogs.com/devinzhang/archive/2012/01/06/2315235.html

南桥北木
48分钟前
1
0
由于PostgreSQL9.x二进制输出格式默认值改变导致的读取图片错误

今天从社区邮件看到一个这样的问题,感觉很有意思,在这分享给大家~具体如下: 问题现象: 作者有一个很老的Java应用,当时后端采用的PostgreSQL数据库版本为8.x,该系统除了正常的数据增删...

闻术苑
今天
2
0
导入sql时出现Invalid default value for 'create_time'报错处理方法

当运行SQL会出现:[Err] 1067 - Invalid default value for 'create_time',是因为Mysql版本不同,如果版本不 < 5.6请去的话报错的处理方法如下: 方法 :alter table table_name modify cre......

writeademo
今天
1
0
对ssm(spring,springmvc,mybatis)的了解总结

ssm框架现在是java web开发的三个主流框架 ,其实严格来算只算是两个框架,因为springmvc属于spring框架 ,是spring的一个mvc子框架 那么我们下面就来了解一下三大框架把 一 .Spring spring...

咸鱼-李y
今天
2
0
聊聊Elasticsearch的FsProbe

序 本文主要研究一下Elasticsearch的FsProbe FsProbe elasticsearch-7.0.1/server/src/main/java/org/elasticsearch/monitor/fs/FsProbe.java public class FsProbe { private static f......

go4it
今天
2
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部