android开发环境类错误
android开发环境类错误
CrazyPumPkin 发表于2年前
android开发环境类错误
  • 发表于 2年前
  • 阅读 97
  • 收藏 0
  • 点赞 1
  • 评论 0

腾讯云实验室 1小时搭建人工智能应用,让技术更容易入门 免费体验 >>>   

摘要: 部分遇到的开发环境类错误


genymotion sign in 时 unknown generic error

网络问题,只要不断地点登陆,失败了再登陆,重复数次一定可以


Unable to start Genymotion virtual device. Unable to initialize OpenGl renderer library. Check if the video card support OpenGL 2.0

分两种情况:

1.机器太旧,显卡或者集显不支持OPENGL2.0,就像之前公司配的机器,年代久远,找了最新的驱动依旧只能支持到OPENGL 1.X,遇到这种情况只能换硬件。

2.显卡驱动没装好,这个要上官网下载最新的驱动,用驱动精灵的话可能会下载到一些奇奇怪怪的东西所以在这一步不推荐。


Subversion Native Library Not Available

eclipse中选择 “Windows” -> Perferences。 然后通过左上方的筛选,选出svn设置菜单,点解左侧的“SVN”。 在设置面板有下方,SVN interface 中,Client选择 SVNKit。然后保存即可。


Android Studio Unknown host ‘downloads.gradle.org’

离线下载gradle


Gradle sync failed: Plugin with id 'com.android.application' not found.

检查build.gradle文件有没配置classpath  com.android.tools.build:gradle

将gradle插件的版本号改至最新,同步,会提示你最低的gradle版本,然后下载该版本的gradle 


Android SDK Content Loader 0%

  1. 强制重启

  2. 强制关闭,删掉C:\Users\用户名\.android文件夹下的所有内容,再重启

  3. 关闭,删掉Eclipse WorkSpace下.metadata\.plugins\org.eclipse.core.resources\.projects文件夹下的所有内容,再重启。

      

Android Studio 下 

Error:Cause: org/gradle/api/publication/maven/internal/DefaultMavenFactory 

当你使用的Gradle版本是2.4及以上,Android插件版本是1.3.0及以上的时候就会出现这个问题,这时候你只需将android-maven-gradle-plugin插件版本改为classpath‘com.github.dcendents:android-maven-gradle-plugin:1.3’即可


org.apache.subversion.javahl.ClientException: svn: E155015: Commit failed (details follow):

svn: E155015: Aborting commit: 'D:\workspace\OilWaiter\OilWaiter' remains in conflict

删除主目录下“dir_conflicts.pref”文件


eclipse 下 导入项目时 Select at least one project

工作空间里有同名项目


Android Studio Gradle DSL method not found: 'android()'

删除最外层build.gradle文件里面的,android{}部分,原有配置转移到各个模块的build.gradle文件

共有 人打赏支持
粉丝 0
博文 2
码字总数 957
×
CrazyPumPkin
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: