文档章节

java.lang.UnsupportedClassVersionError: Mo : Unsupported major.minor version 52.0

 南桥北木
发布于 2017/09/06 23:20
字数 58
阅读 10
收藏 0

花啦半天找到错误的原因,是因为在生成class用的高版本jdk,而在运行的时候用的低版本jdk,把开发工具中的jre换成高版本就行

© 著作权归作者所有

共有 人打赏支持
粉丝 0
博文 186
码字总数 33227
作品 0
武汉
项目在Intellij idea 2.5能运行,但Intellij idea 3不能运行

原来在Intellij idea 2.5里能正常运行的项目,到Intellij idea 3 公开预览版这个版本里怎么就不能正常运行了呢?报jdk版本过低的错,这是怎么回事? Error:Internal error: (java.lang.Unsup...

GKing
2016/10/27
261
2
kafka-manager 的编译和使用(附安装包)

kafka-manager是一个非常好用的kafka web管理工具,yahoo开源。 地址:github.com/yahoo/kafka-manager 1、编译过程比较简单,重点是能翻墙,如果网络环境不允许,可以从本文中的下载链接下载...

王二铁
2016/04/05
3K
6
这是报的什么错 在别人eclipse里好使 到我这就不好使

Exception encountered during context initialization - cancelling refresh attempt org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [com.hzkj.se......

LeBron_
2017/12/14
61
3
jdk版本无法编译的问题

用Jdk1.7编译在tomcat运行时报:java.lang.UnsupportedClassVersionError: org/apache/solr/client/solrj/SolrServerException : Unsupported major.minor version 52.0 (unable to load cla......

心境111
2016/07/06
247
3
jdk1.8下安装jdk1.7后,报Unsupported major.minor version 52.0或Can't load IA 32-bit .dll on a AMD 64-bit platform]错误

之前运行没问题,包括tomcat/jetty/maven都正常,jdk为1.8,后为了运行eova,必须用1.7版本,于是又同时安装了jdk1.7,在tomcat和jetty下都报错。jdk、win7、idea15均为64位,错误如下 : 1、...

zerov
2016/11/23
460
1

没有更多内容

加载失败,请刷新页面

加载更多

原型模式

1、原型模式-定义 用原型实例指定创建对象的种类,并且通过拷贝这些原型创建新的对象 克隆(浅度克隆->拷贝值类型或者引用,深度克隆->创建新的对象,开辟新的内存) 例如客户端知道抽象Pro...

阿元
今天
40
0
awk命令扩展使用操作

awk 中使用外部shell变量 示例1 [root@centos01 t1022]# A=888[root@centos01 t1022]# echo "" | awk -v GET_A=$A '{print GET_A}'888[root@centos01 t1022]# echo "aaaaaaaaaaaaa" | aw......

野雪球
今天
33
0
深入解析MySQL视图VIEW

Q:什么是视图?视图是干什么用的? A:视图(view)是一种虚拟存在的表,是一个逻辑表,本身并不包含数据。作为一个select语句保存在数据字典中的。   通过视图,可以展现基表的部分数据;...

IT--小哥
今天
43
0
虚拟机学习之二:垃圾收集器和内存分配策略

1.对象是否可回收 1.1引用计数算法 引用计数算法:给对象中添加一个引用计数器,每当有一个地方引用它时,计数器值就加1;当引用失效时,计数器值就减1;任何时候计数器值为0的对象就是不可能...

贾峰uk
今天
33
0
smart-doc功能使用介绍

smart-doc从8月份底开始开源发布到目前为止已经迭代了几个版本。在这里非常感谢那些敢于用smart-doc去做尝试并积极提出建议的社区用户。因此决定在本博客中重要说明下smart-doc的功能,包括使...

上官胡闹
昨天
43
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部