android studio 使用+错误总结
博客专区 > LizRose 的博客 > 博客详情
android studio 使用+错误总结
LizRose 发表于2年前
android studio 使用+错误总结
  • 发表于 2年前
  • 阅读 95
  • 收藏 1
  • 点赞 2
  • 评论 0

标题:腾讯云 新注册用户域名抢购1元起>>>   


导入项目

  • 导入eclipse 项目----Import project

似乎会报版本SDK错误问题,然后重构了gradle,不知道什么鬼

 

  • 导入android studio 项目

open an existing android project->

http://www.gezila.com/tutorials/58197.html

1.报错compile 'com.android.support:appcompat-v7:23.0.1'-->解决http://jingyan.baidu.com/album/c74d600080c02a0f6a595d3d.html?picindex=1

找到实际项目里面的build gradle

    compile 'com.android.support:appcompat-v7:23.2.1'
    compile 'com.android.support:design:23.2.1'

将这两行里面的版本内容给改成sdk-》extras->android support library对应的版本号

2.报错

Warning:Gradle version 2.10 is required. Current version is 2.8. If using the gradle wrapper, try editing the distributionUrl in F:\work\qxueyou\gradle\wrapper\gradle-wrapper.properties to gradle-2.10-all.zip

说明你自己as的版本号与项目版本号不对应

解决办法:http://www.ithao123.cn/content-10783272.html

博客中提出了在AS里面在线更新和下载相应gradle压缩包两种办法,第一种在AS里面更新似乎很慢而且没成功,尝试了下载包的办法成功了。更新完成之后再rebuid一下项目就好了。

 

 


unable to access android SDK andd-on list

 

3.error runing mainactivity:instant run requires tools android enable ADB integration

tools-android-》enable ADB InTEGRATION


导入library

方法:http://jingyan.baidu.com/article/1974b2898917aff4b1f77415.html

1,这里会报sdk版本问题,据说是在build.gradle里面修改东西,但是什么鬼,据说要等待sdk更新.

修改librarya目录下的build.gradle中的

buildToolsVersion "23.0.3"

编译一次项目之后会出现R文件报错->rebuild project

2.Error:No such property: GROUP for class: org.gradle.api.publication.maven.in

解决-》在AS里,左上角将项目的显示方式改为project,然后找到你导入的库的文件夹,点开,打开其build.gradle文件,然后你注释掉最后一行代码(与maven有关的,比如我的是:

//apply from: './gradle-mvn-push.gradle'

),重新build一下就OK了
 


sdk版本

http://stackoverflow.com/questions/19465049/changing-api-level-android-studio


.java.lang.IllegalStateException: You need to use a Theme.AppCompat theme

将activity改为继承activity

 

 

共有 人打赏支持
粉丝 2
博文 44
码字总数 33108
×
LizRose
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: