Xcode7 编译报错 -fembed-bitcode 错误
Xcode7 编译报错 -fembed-bitcode 错误
王素年 发表于2年前
Xcode7 编译报错 -fembed-bitcode 错误
  • 发表于 2年前
  • 阅读 26
  • 收藏 0
  • 点赞 0
  • 评论 0

【腾讯云】新注册用户域名抢购1元起>>>   

摘要: clang: error: -fembed-bitcode is not supported on versions of iOS prior to 6.0

意思说 :- fembed bitcode 不支持iOS 6之前的版本 


先说解决办法:在Build Settings 中搜索Enable Bitcode ,将其中的YES 改成 NO  就ok了


简单说一下原因:Xcode7中,对于iOS应用来说,Bitcode是可选的,但对于如今新出的watchOS而言,Bitcode是必须的。现在由于我们的工程中使用了未包含bitcode框架,导致编译失败。所以,我们需要找Enable Bitcode选项,将默认的 Yes 改为 No 即可临时解决这个问题。那什么时候可以彻底根治这个问题呢,只有等到你工程中所有使用的框架均支持Bitcode才行。

标签: - fembed bitcode
  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 1
博文 70
码字总数 43954
×
王素年
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: