sdk 与adt不适用,在eclipse 中删除版本再装引起的问题

原创
2015/09/09 22:52
阅读数 1K

eclipse 使用的是4.3版本的,sdk 使用24.3.2,这里的是一个全量包来的,就是从24.3.2 以下的版本都包括在里面了,而 adt 只找到最高 23.06 一开始还能用着,但是,因版本不对称,总是要在里面降低sdk的版本,很麻烦,就想着直接在eclipse 里面运行SDK Manager 将 24.3.2  的版本文件删除,留下23.0.2那些,但是,在里面删了24.3.2 后,再去行eclipse 后就出错了,说没有了sdk文件什么的了,于是就再下载一个只有 23.0.2 版本的 sdk ,将其反回到 sdk 目录里,这样,运行是可以运行了,但是,发现sdk 23.0.2 还是不能与 adt 23.0.6 适用,而在里面选更低版本就可用,于是,又删除sdk 的 23.0.2文件,再下载23.0版本的 sdk 装进 sdk 目录里,但是这时,运行 eclipse 正常,可建立 app项目到最后一步时,就出问题了,最后一步按  finish 后,这个页面不会象正常的那些,生成一个项目后就消失,他还是在这里,而项目是生成了,可是有红色的 X  而还有红色的错误提示

[2015-09-09 14:13:48 - daytime] D:\Android\workspace\daytime\res\values\styles.xml:7: error: Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Light'.
[2015-09-09 14:13:48 - daytime] 
[2015-09-09 14:13:48 - daytime] D:\Android\workspace\daytime\res\values-v11\styles.xml:7: error: Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Light'.
[2015-09-09 14:13:48 - daytime] 
[2015-09-09 14:13:48 - daytime] D:\Android\workspace\daytime\res\values-v14\styles.xml:8: error: Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Light.DarkActionBar'.
[2015-09-09 14:13:48 - daytime] 


这就麻烦了,

找了好久,才找到这里有人解答 http://stackoverflow.com/questions/21059612/no-resource-found-that-matches-the-given-name-style-theme-appcompat-light

全是鸡肠,想来,不再对 eclipse进行更新支持还是好麻烦的啊,还是要学习studio啊

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部