ubuntu下安装adb工具集与android-tools-adb产生冲突的问题
ubuntu下安装adb工具集与android-tools-adb产生冲突的问题
soul行衍 发表于7个月前
ubuntu下安装adb工具集与android-tools-adb产生冲突的问题
  • 发表于 7个月前
  • 阅读 10
  • 收藏 0
  • 点赞 0
  • 评论 0

华为云·免费上云实践>>>   

因为项目原因需要安装厂家自有得adb工具集:

当需要:

“正试图覆盖 /usr/bin/adb,它同时被包含于软件包 android-tools-adb 4.2.2+git20130218-3ubuntu23dpkg-deb: error: subprocess 粘贴 was killed by signal (Broken pipe)”

发生冲突,报错:

“E: Sub-process /usr/bin/dpkg returned an error code (1)“

且带有如下信息:

【警告】:下列软件包不能通过验证!

此时使用命令强制复写即可解决问题:

”sudo apt-get -o Dpkg::Options::="--force-overwrite" install semc-devenv-adb“

 

标签: bug fix
共有 人打赏支持
粉丝 0
博文 15
码字总数 5622
×
soul行衍
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: