关于iOS 报Command failed with exit 128: git错误额解决方案

原创
2022/06/15 20:24
阅读数 6.9K

最近在运行pod install 命令报了一个错误,日志如下:

pod install 
zsh: /Users/xzh/.rvm/gems/ruby-3.0.0/bin/pod: bad interpreter: /Users/xzh/.rvm/rubies/ruby-3.0.0/bin/ruby: no such file or directory
/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/universal-darwin21/rbconfig.rb:230: warning: Insecure world writable dir /opt/homebrew/bin in PATH, mode 040777
/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/dependency.rb:311:in `to_specs': Could not find 'cocoapods-core' (= 1.11.3) among 37 total gem(s) (Gem::MissingSpecError)
Checked in 'GEM_PATH=/Users/xzh/.rvm/gems/ruby-3.0.0:/Users/xzh/.rvm/rubies/ruby-3.0.0/lib/ruby/gems/3.0.0', execute `gem env` for more information
	from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1449:in `block in activate_dependencies'
	from /System/Library/Frameworks/Ruby.framework/Version

本文同步分享在 博客“xiangzhihong8”(CSDN)。
如有侵权,请联系 support@oschina.cn 删除。
本文参与“OSC源创计划”,欢迎正在阅读的你也加入,一起分享。

展开阅读全文
加载中
点击引领话题📣 发布并加入讨论🔥
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部