debian 7 下的一些错误提示解决办法
博客专区 > hiwill 的博客 > 博客详情
debian 7 下的一些错误提示解决办法
hiwill 发表于2年前
debian 7 下的一些错误提示解决办法
  • 发表于 2年前
  • 阅读 80
  • 收藏 0
  • 点赞 0
  • 评论 0

腾讯云 新注册用户 域名抢购1元起>>>   

1、修改系统时间
cp /usr/share/zoneinfo/Asia/ShangHai /etc/localtime #时区为亚洲/上海
date 命令查看

2、用惯了vim,在debian下你会发现vi中无法使用delete和backspace键。
原来Debian中自带的vi是vim-tiny,程序本身就不支持Backspace删除功能。

解决办法:重新安装其他版本的vi
apt-get update
apt-get install -y vim vim-runtime
 

3、提示-bash: killall: command not found
debian下
apt-cache search killall
apt-get install psmisc

centos下
yum search killall
yum install -y psmisc

4、安装libc6
在debian 7 x86_64下安装软件时提示错误:
Depends: libc6 (>= 2.14) but 2.13-38+deb7u8 is to be installed
E: Unable to correct problems, you have held broken packages.

添加Jessie的源更新就好了
echo "deb ftp://ftp.debian.org/debian/ jessie main 
deb-src ftp://ftp.debian.org/debian/ jessie main" >> /etc/apt/sources.list
apt-get update
apt-get upgrade

5、debian 系统,发现没有libpcap-dev 。解决方法:更新源

#vi /etc/apt/sources.list 添加下列源
deb http://ftp.debian.org/debian lenny main contrib non-free
deb-src http://ftp.debian.org/debian lenny main contrib non-free
deb http://mirrors.163.com/debian lenny main contrib non-free
deb-src http://mirrors.163.com/debian lenny main contrib non-free
然后# apt-get update
    # apt-get upgrade

6、出现错误提示:
"libcurl.so.4: cannot open shared object file: No such file or directory"

解决办法
apt-get update
apt-get install -y curl
 

7、获得中国的所有ip
wget http://www.ipdeny.com/ipblocks/data/countries/cn.zone

$IPTABLES -A INPUT -s $ip -j DROP
需要注意的是Debian上iptables是不会保存规则的

共有 人打赏支持
粉丝 10
博文 109
码字总数 64459
×
hiwill
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: