npm升级package如何对应的更新package.json中的版本号

原创
2019/05/27 17:13
阅读数 1.5K

今天在项目中用npm start 启动一个项目,报如图错误,网上查了之后,是因为package.json文件中,http-server版本太低引起的(我的是0.6.1),解决方法有两种

第一种方法 直接在文件中修改http-server的版本为0.9.0,这样再次启动没有报错。

第二种方法直接用npm update 方法更新,但是更新后发现package.json中对应的版本号并没有改变,于是查阅了一些资料和文章,借助npm-check-updates工具可以很方便的将package.json中的依赖包版本号更新为最新版本,下面介绍下该工具的使用,

安装 --npm install npm-check-updates -g

使用:1 检查depedencies中的最新版本 npm-check-updates 或者ncu    2 更新dependencies到最新版本 ncu -u 

这样depedencies中的版本号自动更新到最新版本。

如果想更新全部depedencies到最新版本(包括当前指定版本范围满足最新版本号)ncu -a 

展开阅读全文
加载中

作者的其它热门文章

打赏
0
0 收藏
分享
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部