javac -version ;java -version不一致

原创
2014/04/18 17:00
阅读数 113

近两天碰到一个问题,在部署之前已经成熟的WEB项目到TOMCAT下运行,死活老是报servlet调用service服务NullException。将服务折腾了很久,终于在老手的帮助下找到了原因,这个原因出来,貌似会恍然大悟:

     java -version :jdk 1.6

    javac -version:jdk 1.7

后面查看环境变量里面,设置了PATH为jdk1.6的路径;无设置classpath,但是又升级安装为jre1.7.

问题的解决是重新安装JDK1.7的环境,配置路径。但是为什么版本会不一致,未找到具体原因。

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部