文档章节

实战系列之单臂驿站(3)

s
 start0cheng
发布于 2015/02/09 23:14
字数 1000
阅读 3
收藏 0
单臂驿站(3)
各位江湖朋友,如果你看过了我的前两节,希望不要因为我写的比较枯燥让大伙丢失了继续看完的决心.我觉得我应该在这里解释一下我的主题.
 
在一节,我讲的是路由这一块的.大伙想想,路由是什么?很容易是理解,那就是把数据从一个网络转发到另一个网络的过程,称之为路由.那么,今天我说的驿站呢?驿站也是从一个地方到另一个地方的中转站.在意见上有些相似.在一定程度上就像我们理解路由器一样.希望这个比喻不是太差.....没办法.很久没有动笔,文章也很少写.所以大家很容易理解我要说的是 单臂路由.
 
本次我在原本的基础上进行了改进。无奈,我的那张拓补图画的有些难看,我自己都这么认为。以后在这方面要加强! 。此次我讲的是实验环境中的优化网络这一个系列中的cisco部分,真诚的希望大家会喜欢。当然,在后续我会把active directory、DNS、DHCP、WSUS、LCS、Exchange部分加进来。希望以这样一个系列来加深与巩固自己的知识,也同大家一起来分享我的经验,如果大家能给我一些建议那自然是最好的了。。。。
 
好的,不多说费话。我们开始吧。
 
OK,我们在做的时候,不用去看上面的图,我们看下面这个图更容易理解!
 
这样看来,是不是更容易说明问题呢?
OK,大家看我的试验步骤:
首先第一步,我们需要理清目前的网络接口配置情况.
在这个实验中使用了一个cisco Router 2600系列中的一款及cisco switch layer 3 3550.其他的均为普通交换机.因为使用的是模拟器,我会关掉所有路由器的上ip routing功能.在本次实验中,我只提供了三层交换机与路由器的配置.稍后会提供计算机的配置给你.

Router:
hostname:2600
fa0/1:需要启用三个子接口,并启用IP routing
子接口:172.16.2.1/24,172.16.3.1/24,172.16.4.1/24
 
switch:(为防止实验失败,关闭ip routing功能)
hostname:3550
fa8/24:trunk
vlan:
vlan2:fa1/24 (gateway:172.16.2.1/24)
vlan3:fa21/24(gateway:172.16.3.1/24)
vlan4:fa24/24(gateway:172.16.4.1/24)
 
客户端计算机:
处于Vlan 2的计算机可以
配置IP范围:172.16.2.2~172.16.2.254
gateway:172.16.2.1
 
处于Vlan 3的计算机可以
配置IP范围:172.16.3.2~172.16.3.254
gateway:172.16.3.1
 
处于Vlan 4的计算机可以
配置IP范围:172.16.4.2~172.16.4.254
gateway:172.16.4.1
 
开始看配置:
Router部分:
Router(config)#hostname 2600
2600(config)#interface fa0/1.2
2600(config-subif)# encapsulation dot1q 2
2600(config-subif)#ip add 172.16.2.1 255.255.255.0
2600(config-subif)#no shutdown
2600(config-subif)#exit
2600(config)#interface fa0/1.3
2600(config-subif)#encapsulation dot1q 3
2600(config-subif)#ip add 172.16.3.1 255.255.255.0
2600(config-subif)#no shutdown
2600(config-subif)#exit
2600(config)#interface fa0/1.4
2600(config-subif)#encapsulation dot1q 4
2600(config-subif)#ip add 172.16.4.1 255.255.255.0
2600(config-subif)#no shutdown
2600(config-subif)#exit
2600(config)#ip routing
2600(config)#interface fa0/1
2600(config-if)#speed 100
2600(config-if)#duplex full
2600(config-if)#no shutdown
 
Switch:
switch(config)# hostname 3550
3550(config)#vlan database
3550(config-vlan)#vlan 2 name O
3550(config-vlan)#vlan 3 name B
3550(config-vlan)#vlan 2 name C
3550(config-vlan)#exit
3550(config)#interface fa8/24
3550(config-if)#switchport mode trunk
3550(config-if)#switchport trunk encapsulation dot1q
3550(config-if)#no shutdown
3550(config-if)#exit
3550(config)#interface fa1/24
3550(config-if)#switchport mode access
3550(config-if)#switchport access vlan 2
3550(config-if)#exit
3550(config)#interface fa21/24
3550(config-if)#switchport mode access
3550(config-if)#switchport access vlan 3
3550(config-if)#exit
3550(config)#interface fa24/24
3550(config-if)#switchport mode access
3550(config-if)#switchport access vlan 4
3550(confi-if)#exit
 
Vlan 2下的计算机IP的配置
Windows IP Configuration
        Host Name . . . . . . . . . . . . : Bnsen
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
Ethernet adapter 本地连接:
        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethe
rnet NIC
        Physical Address. . . . . . . . . : 00-16-5B-99-3D-32
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 172.16.2.2
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 172.16.2.1
 
 

本文出自 “潜入技术的海洋” 博客,请务必保留此出处http://myhat.blog.51cto.com/391263/79915

本文转载自:http://myhat.blog.51cto.com/391263/79915

s
粉丝 3
博文 260
码字总数 0
作品 0
广州
私信 提问
目录(V1.1)

欢迎IT爱好者关注微信公众号:小道讯息 Email:admin@iters.top 路由交换 Cisco三层交换机配置命令及解释 最简单的DHCP配置 路由器最简单的DHCP实验 RIP改static静态 华为交换机基础命令、配置...

小道讯息
2017/07/10
0
0
双十一需要仪式感,包邮送15本实体书 | 粉丝福利第⑤期 |

  ps:想到明天就是11.11光棍节,今日注定脱光无望,在这没有情人的光棍节,感谢北京大学为我们(Java进阶架构师,Java技术驿站,方志朋)赞助了6种共15本书!希望大家都能中奖抱着书本摩擦...

java进阶架构师
2018/11/10
0
0
Juniper-SSG系列之子接口(单臂路由)运用

一、网络结构 二、分析与预规划 规划如上图↑ 分析客户目前暂定的拓扑方案,实现多vlan间通信。G0/0/48端口做成Trunk,理论上SW-A默认只会让10.10.0.X/24的主机过,Juniper防火墙Ping vlanif...

王占兴
2018/01/09
0
0
曾垂鑫的51CTO视频集锦入口(长期更新)

自入驻51CTO学院以来,已经发布的视频课程如下 Exchange邮件管理系列 Exchange Server 2016管理系列【第一季】:部署与新特性(共37课时)在线自学视频教程51CTO学院 http://edu.51cto.com/c...

zengchuixin2008
2015/01/16
0
0
单臂路由2-三层交换机实现

要不同Vlan间进行通信可以利用单臂路由技术。单臂路由可以使用路由器,也可以使用三层交换机进行配置。 拓扑结构: 1.PC机IP地址如图所示。 2.二层交换机配置: 划分vllan并添加端口: 给f0/...

阿仙儿
2017/04/26
0
0

没有更多内容

加载失败,请刷新页面

加载更多

golang-字符串-地址分析

demo package mainimport "fmt"func main() {str := "map.baidu.com"fmt.Println(&str, str)str = str[0:5]fmt.Println(&str, str)str = "abc"fmt.Println(&s......

李琼涛
今天
4
0
Spring Boot WebFlux 增删改查完整实战 demo

03:WebFlux Web CRUD 实践 前言 上一篇基于功能性端点去创建一个简单服务,实现了 Hello 。这一篇用 Spring Boot WebFlux 的注解控制层技术创建一个 CRUD WebFlux 应用,让开发更方便。这里...

泥瓦匠BYSocket
今天
6
0
从0开始学FreeRTOS-(列表与列表项)-3

FreeRTOS列表&列表项的源码解读 第一次看列表与列表项的时候,感觉很像是链表,虽然我自己的链表也不太会,但是就是感觉很像。 在FreeRTOS中,列表与列表项使用得非常多,是FreeRTOS的一个数...

杰杰1号
今天
8
0
Java反射

Java 反射 反射是框架设计的灵魂(使用的前提条件:必须先得到代表的字节码的 Class,Class 类 用于表示.class 文件(字节码)) 一、反射的概述 定义:JAVA 反射机制是在运行状态中,对于任...

zzz1122334
今天
5
0
聊聊nacos的LocalConfigInfoProcessor

序 本文主要研究一下nacos的LocalConfigInfoProcessor LocalConfigInfoProcessor nacos-1.1.3/client/src/main/java/com/alibaba/nacos/client/config/impl/LocalConfigInfoProcessor.java p......

go4it
昨天
9
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部