文档章节

Struts配置文件错误之type "package"

金武飞扬
 金武飞扬
发布于 2016/03/29 19:40
字数 74
阅读 8
收藏 0


错误信息:

The content of element type "package" must match "(result-types?,interceptors?,default-interceptor-

 ref?,default-action-ref?,default-class-ref?,global-results?,global-exception-mappings?,action*)".

原因:package里元素必须按照一定的顺序排列

result-types
interceptors
default-interceptor-ref
default-action-ref
default-class-ref
global-results
global-exception-mappings
action*(所有action放到最后)


© 著作权归作者所有

共有 人打赏支持
金武飞扬
粉丝 4
博文 8
码字总数 1010
作品 0
商丘
程序员
私信 提问
spring2.5 管理sturts2 action问题

今天小弟着实悲剧了很长时间 麻烦各位兄台抽空看下 网速有问题 就直接贴了 struts配置文件 struts-index.xml配置文件 /index.jsp spring部分配置文件 web.xml配置 部分 contextConfigLocatio...

编码小兵
2011/07/29
1K
1
struts.xml配置错误,出现了问题

出现问题如下: 警告: Could not find action or result: /RequireManagement/action/RequirementAction There is no Action mapped for action name RequirementAction. - [unknown locati......

wangxuxu
2016/09/23
197
2
Java:struts2之struts.xml 配置详解整理........ing

<!DOCTYPE struts PUBLIC "-//Apache Software Foundation//DTD Struts Configuration 2.0//EN" "http://struts.apache.org/dtds/struts-2.0.dtd" > <struts> <!-- include节点是struts2中组......

刘纪君
2014/03/14
0
0
struts 2.0 的 struts.xml 配置文件详解

/error.jsp /talk.jsp http://www.sina.com 转自 http://www.iteye.com/topic/1060457

鉴客
2011/05/30
330
2
struts2.0中struts.xml配置文件详解

/error.jsp /talk.jsp http://www.sina.com

crazyinsomnia
2010/03/25
563
0

没有更多内容

加载失败,请刷新页面

加载更多

Vue.js开发环境搭建说明(mac)

vue开发环境搭建(mac) 投影放大:cmd + + 安装Node 下载Node 官网下载 https://nodejs.org/en/download/ 安装Node 双击安装包,选择安装目录,比如: /usr/local/bin 安装成功后最好记录一...

Danni3
8分钟前
1
0
Qt编写自定义控件3-速度仪表盘

前言 速度仪表盘,写作之初的本意是用来展示当前测试的网速用的,三色圆环+数码管显示当前速度,Qt自带了数码管控件QLCDNumber,直接集成即可,同时还带有动画功能,其实也可以用在汽车+工业...

飞扬青云
13分钟前
0
0
【论文阅读】Image Super-Resolution via Deep Recursive Residual Network

题目:通过深度递归残差网络实现图像的超分辨率 摘要: 近年来,基于卷积神经网络的模型在单张图像的超分辨率上已经取得了巨大的成功。由于深度网络的强大,这些CNN模型学习了从低分辨率输入...

云烟成雨forever
15分钟前
0
0
为什么强烈建议大家使用枚举来实现单例

关于单例模式,我的博客中有很多文章介绍过。作为23种设计模式中最为常用的设计模式,单例模式并没有想象的那么简单。因为在设计单例的时候要考虑很多问题,比如线程安全问题、序列化对单例的...

群星纪元
34分钟前
11
0
Confluence 6 超过当前许可证期限进行升级

这个页面将会对你在进行 Confluence 升级的时候超过了当前许可证的期限进行升级的情况。 许可证警告 在升级的过程中,你将会在 Confluence 的应用程序日志(log file)中看到类似下面的错误提...

honeymoose
47分钟前
2
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部