文档章节

在UbuntuKylin15.04上安装GIScript2015

openthings
 openthings
发布于 2015/06/24 11:39
字数 651
阅读 320
收藏 0

GIScript入门教程参见:http://my.oschina.net/u/2306127/blog/484213,这里介绍基于SIP的C++封装为Python的方法和使用过程。


GIScript2015版采用了新的SIP封装,从而可以更好地与C++接口保持一致。

最近有了一些进展,尝试在在UbuntuKylin15.04上安装GIScript。

由于要使用MetaSIP,需要Python3,先输入python3确认一下当前的环境。

安装python3

sudo apt-get install python-pip
sudo apt-get install python3-dev

安装SIP

#下载:http://www.riverbankcomputing.com/software/sip/download
wget http://sourceforge.net/projects/pyqt/files/sip/sip-4.16.8/sip-4.16.8.tar.gz
#解压
tar -vxf sip-4.16.8.tar.gz
#配置
cd sip-4.16.8
python3 configure.py
#编译
make
#安装
sudo make install

如果出现下述错误:

PyQt5 - SIP API 10 level error. API 11 required

一般是系统的SIP版本有多个引起的,一般存在两个地方:/usr/bin/sip.so和usr/library/python3.*/site-packages,两个版本必须一致。

测试是否版本不一致:sip -V和在python中import sip ,然后执行print(sip.SIP_VERSION_STR),二者显示的版本好必须完全一致。

如果不一致,执行下面的操作,把版本清除掉,然后重新安装(或者进相应的目录,然后手工清除。)

sudo rm /usr/bin/sip.so
sudo rm /usr/lib/python3/dist-packages/sip*
sudo rm /usr/lib/python3.x/site-packages/sip*

安装MetaSIP

#下载
wget http://www.riverbankcomputing.com/hg/metasip/archive/tip.zip
#解压
tar -vxf 
#编译、安装
#老是报错

注意:执行python setup.py install时,如果报如下错误


则查看dip目录下是否有VERSION文件(一般报错是没有的^_^),则新建一个VERSION,内容为56a217326678.

安装QScintilla2

#下载
wget http://sourceforge.net/projects/pyqt/files/QScintilla2/QScintilla-2.9/QScintilla-gpl-2.9.tar.gz
#解压
tar -vxf QScintilla-gpl-2.9.tar.gz
#编译、安装
cd QScintilla-gpl-2.9
cd Qt4Qt5
qmake qscintilla.pro
make
make install

安装DIP

#下载
wget http://www.riverbankcomputing.com/static/Downloads/dip/dip-gpl-0.4.4.tar.gz
#解压
tar -vxf dip-gpl-0.4.4.tar.gz
#编译、安装
cd dip-gpl-0.4.4
sudo python setup.py install

安装gccxml

参考:http://gccxml.github.io/HTML/Install.html

sudo apt-get install git
git clone git://github.com/gccxml/gccxml.git
mkdir gccxml-build
cd gccxml-build
cmake ../gccxml
make
make install

安装QT

到http://www.qt.io/download/,下载相应的版本并安装。

安装PyQT

#下载:http://www.riverbankcomputing.com/software/pyqt/download
wget http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-5.4.2/PyQt-gpl-5.4.2.tar.gz
#解压
tar -vxf PyQt-gpl-5.4.2.tar.gz
#配置
cd PyQt-gpl-5.4.2
python3 configure.py
#编译
make
#安装
sudo make install

使用MetaSIP创建封装工程的SIP文件


使用SIP文件创建C++封装接口

C++封装接口编译

测试封装的接口


© 著作权归作者所有

openthings
粉丝 323
博文 1140
码字总数 689435
作品 1
东城
架构师
私信 提问
GIScript2015的第一个入门教程-使用UbuntuKylin15.04

GIScript2015是一个通用的GIS脚本库,可以帮助进行地理空间数据的处理和分析,提高数据处理的效率,帮助进行地理科学的研究。GIScript2015是一个开源工程,已建立Git版本库和虚拟Team、微信群...

openthings
2015/07/27
488
0
UbuntuKylin15.04安装SM iObjects C++库

GIScript2015版采用SIP对iObjects C++库进行封装,可以直接调用其功能。当然了,SIP的封装方法可以封装任意的C/C++库,你可以随意去扩展它,与各种各样的库联合进行使用,简单、灵活、自由而...

openthings
2015/07/09
105
0
GIScript/GIScript2016

#GIScript2016 时空数据分析开放脚本引擎2016版本,使用MetaSIP和SIP将SuperMap iObjects C++封装为Python脚本使用。 采用SIP技术可以将任何C++的库封装为Python脚本使用,通过将该技术开放使...

GIScript
2016/10/12
0
0
ROS-Jade版在UbuntuKylin15.04上的安装

Ubuntu install of ROS Jade We are building Debian packages for several Ubuntu platforms, listed below. These packages are more efficient than source-based builds and are our pre......

openthings
2015/07/20
870
0
Qt5.5和PyQt5.5在UbuntuKylin15.04的快速安装脚本

Qt5.5已经发布了,前两天PyQt也很快推出了一个5.5的对应版本。试验了一下(花了个周末啊!),真是越来越好用了。Qt5.5在Ubuntu15.04上有一些重要的改进,在虚拟机里运行的窗口覆盖问题也终于...

openthings
2015/07/27
877
0

没有更多内容

加载失败,请刷新页面

加载更多

sync 包讲解

sync.Once Once 的作用是多次调用但只执行一次,Once 只有一个方法,Once.Do(),向 Do 传入一个函数,这个函数在第一次执行 Once.Do() 的时候会被调用,以后再执行 Once.Do() 将没有任何动作...

李琼涛
19分钟前
3
0
java中的byte占一字节或4字节

https://www.jianshu.com/p/2f663dc820d0

南桥北木
33分钟前
4
0
Cassandra 常用命令

Linux控制台命令 #进入Cassandra的安装目录 cd /home/db/cassandra/cassandra #进入Cassandra 无密码 ./bin/cqlsh localhost(IP)有密码 ./bin/cqlsh localhost(IP)-u 用户名 #显示所...

最菜最菜之小菜鸟
38分钟前
4
0
自建redis笔记

自建redis笔记 最近在linux安装了一下redis,特做一些笔记! 本文先单节点启动redis,然后再进行持久化配置,在次基础上,再分享搭建主从模式的配置以及Sentinel 哨兵模式及集群的搭建 单节点...

北极之北
46分钟前
4
0
扛住阿里双十一高并发流量,Sentinel是怎么做到的?

Sentinel 承接了阿里巴巴近 10 年的双十一大促流量的核心场景 本文介绍阿里开源限流熔断方案Sentinel功能、原理、架构、快速入门以及相关框架比较 基本介绍 1 名词解释 服务限流 :当系统资源...

分布式系统架构
54分钟前
7
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部