文档章节

OpenSCAD函数一览表

openthings
 openthings
发布于 2015/04/07 07:57
字数 194
阅读 928
收藏 0

    OpenSCAD支持很多种造型函数,基本上涵盖了常规编程语言的全部特征,下面列出25015.3版的函数一览表(这里http://www.openscad.org/cheatsheet/index.html 看详细解释)。

    如果还有更高级的需求,也可以使用其它语言(如Python)来创建*.scad文件,然后到OpenSCAD中进行渲染。如果模型过于复杂,渲染时间太长的话,可以考虑使用命令行在后台进行渲染。当然,如果有多核的CPU,也可以多开几个进程,充分利用多CPU的并行处理能力。



© 著作权归作者所有

openthings
粉丝 302
博文 1110
码字总数 636345
作品 1
东城
架构师
私信 提问
OpenSCAD中使用include或use引入外部库

一、OpenSCAD 使用include或use引入外部库 本文英文版本参考:https://en.wikibooks.org/wiki/OpenSCADUserManual/IncludeStatement ===========================...

openthings
2015/04/07
0
0
OpenSCAD使用总结-中文

OpenSCAD是用程序的方式生成模型,搞软件的人应该很熟悉这种方式,但习惯交互式造型设计的就不用看这个了。创建模型的方法就像是用脚本语言编写一段程序,然后编译,总体感觉简单、便捷、易学...

openthings
2015/01/29
0
0
UbuntuKylin15.04编译OpenSCAD源码

OpenSCAD(http://www.openscad.org)是一个简单高效的三维建模软件,使用模型描述脚本进行建模,使用CGAL引擎进行几何体的空间布尔运算。这里介绍其源码编译方法,使用UbuntuKylin15.04. 把下...

openthings
2015/08/03
0
0
OpenSCAD 2015.03的大变化,更方便了。

OpenSCAD 2015.03出来了,有几个大的变化: 1、增加工具按钮,操作起来更方便,尤其是在Mac OS X的窗口全屏模式下。 2、坐标的标尺显示尺寸的刻度,这个对3D打印的模型设计很方便。 3、代码编...

openthings
2015/03/14
0
0
玩转树莓派-RaspBerry,3D打印个御用外壳

网上已经有很多种外壳出售,可以直接购买。 但你也许不满意与别人雷同,想要做出自己的创意,或者是要满足一些特殊的需求。 那么用先进的3D打印技术,将很容易实现这一点。 即使没有3D打印机...

openthings
2015/03/17
0
0

没有更多内容

加载失败,请刷新页面

加载更多

spring 本类中方法调用另外一个方法事务不生效

1、在spring配置文件中添加 <aop:aspectj-autoproxy expose-proxy="true"/> 声明自动代理 2、AopContext.currentProxy()来获取代理类 3、使用代理类proxy进行代理调用内部声明了事务的方法 ......

重城重楼
5分钟前
0
0
项目 banner 乱弹

------------------------------------------ 村上春树 ------------------------------------- 如果我爱你,而你也正巧爱我,你头发乱了的时候,我会笑笑地替你拨一拨,然后手还留恋地在你...

宿小帅
17分钟前
0
0
PHP获取未来七天的日期和星期

php获取未来七天的日期和星期代码 第一步:获取需要天数的日期,然后调用函数 //获取未来七天的日期 for($i=1;$i<8;$i++){ $dateArray[$i]=date('Y-m-d',strtotime(d...

一只懒猫-
29分钟前
0
0
总结:IO模型

分类 多路复用 参考文章: https://www.jianshu.com/p/6a6845464770 https://www.cnblogs.com/zingp/p/6863170.html https://blog.csdn.net/sehanlingfeng/article/details/78920423......

浮躁的码农
32分钟前
0
0
fabric-sdk-java 1.4安装说明

Hyperledger Fabric Java SDK是开发基于Hyperledger Fabric区块链的Java应用之必备开发包。本文将介绍如何在Maven、Gradle和Eclipse中安装使用最新1.4版本的Hyperledger Fabric Java SDK。 ...

汇智网教程
33分钟前
1
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部