redhat 换163的yum源
博客专区 > hotsmile 的博客 > 博客详情
redhat 换163的yum源
hotsmile 发表于1个月前
redhat 换163的yum源
  • 发表于 1个月前
  • 阅读 5
  • 收藏 0
  • 点赞 0
  • 评论 0

腾讯云 十分钟定制你的第一个小程序>>>   

Redhat6.4配置Centos6 yum替换

1、卸载掉系统redhat自带的yum

  rpm -qa |grep yum |xargs rpm -e --nodeps

 

下载相关的centos yum插件

  主要有python-iniparse-0.3.1-2.1.el6.noarch.rpm 

 yum-3.2.29-40.el6.centos.noarch.rpm

 yum-metadata-parser-1.1.2-16.el6.x86_64.rpm

 yum-plugin-fastestmirror-1.1.30-14.el6.noarch.rpm

 

  其中版本号和安装的系统版本,以及时32位系统和64位系统有关系

  下载地址:http://mirrors.163.com/centos/

 

  在linux可以使用命令直接下载到本地也可以

  wget http://mirrors.163.com/centos/6/os/x86_64/Packages/python-iniparse-0.3.1-2.1.el6.noarch.rpm

  wget http://mirrors.163.com/centos/6/os/x86_64/Packages/yum-metadata-parser-1.1.2-16.el6.x86_64.rpm

  wget http://mirrors.163.com/centos/6/os/x86_64/Packages/yum-3.2.29-40.el6.centos.noarch.rpm

  wget http://mirrors.163.com/centos/6/os/x86_64/Packages/yum-plugin-fastestmirror-1.1.30-14.el6.noarch.rpm

注意,如果提示找不到,进入这个目录找

http://mirrors.163.com/centos/6/os/x86_64/Packages/http://mirrors.163.com/centos/6/os/x86_64/Packages/

3 安装下载的yum包(如果没权限可以先修改权限 chmod 777 *)

 

 rpm -ivh python-iniparse-0.3.1-2.1.el6.noarch.rpm

 rpm -ivh yum-metadata-parser-1.1.2-16.el6.x86_64.rpm

 rpm -ivh yum-3.2.29-40.el6.centos.noarch.rpm yum-plugin-fastestmirror-1.1.30-14.el6.noarch.rpm

 

  最后两个需要一起安装,有相互依赖关系

 

最后一步,如果提示如下信息

error: Failed dependencies:

python-urlgrabber >= 3.9.1-10 is needed by yum-3.2.29-

 

需要安装一个升级包,

http://mirrors.163.com/centos/6/os/x86_64/Packages/python-urlgrabber-3.9.1-11.el6.noarch.rpm

执行安装命令 rpm -Uvh python-urlgrabber-3.9.1-11.el6.noarch.rpm

再安装上面的2个包

# 添加163的yum源 
cd /etc/yum.repos.d 
wget http://mirrors.163.com/.help/CentOS6-Base-163.repo 
sed -i 's/\$releasever/6/g' CentOS6-Base-163.repo 

# 清理yum缓存 
yum clean all 

# 将服务器上的软件包信息缓存到本地,以提高速度 
yum makecache 

如果要安装aapt环境,需要安装32位的环境,

yum install glibc.i686
yum install zlib.i686

yum install libstdc++.i686

安装 c++时有可能和系统安装的64位的c++冲突,yum不让安装:

 Protected multilib versions: libstdc++-4.4.7-16.el6.i686 != libstdc++-4.4.7-4.el6.x86_64

解决办法是解除yum的保护,然后安装即可:

yum install libstdc++.i686 --setopt=protected_multilib=false

 

至此,aapt的环境完成安装

 

 

 

标签: aapt yum
共有 人打赏支持
粉丝 4
博文 41
码字总数 19865
×
hotsmile
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: