Linux上安装MySQL时出现不兼容的解决办法
博客专区 > Carl_ 的博客 > 博客详情
Linux上安装MySQL时出现不兼容的解决办法
Carl_ 发表于3年前
Linux上安装MySQL时出现不兼容的解决办法
  • 发表于 3年前
  • 阅读 22
  • 收藏 0
  • 点赞 0
  • 评论 0

新睿云服务器60天免费使用,快来体验!>>>   

Linux上安装MySQL时出现不兼容的解决办法:

[root@localhost ~]# rpm -ivh MySQL-server-5.5.24-1.linux2.6.x86_64.rpm 
Preparing...                ########################################### [100%]
        file /usr/share/mysql/charsets/README from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/Index.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/armscii8.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/ascii.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/cp1250.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64
        file /usr/share/mysql/charsets/cp1251.xml from install of MySQL-server-5.5.24-1.linux2.6.x86_64 conflicts with file from package mysql-libs-5.1.61-1.el6_2.1.x86_64

原因是系统已经安装了其他版本的mysql-libs包导致不兼容。

[root@localhost ~]# yum list | grep mysql   

mysql-libs.x86_64                    5.1.61-1.el6_2.1          @updates         
apr-util-mysql.x86_64                1.3.9-3.el6_0.1           base             
bacula-director-mysql.x86_64         5.0.0-9.el6               base             
bacula-storage-mysql.x86_64          5.0.0-9.el6               base             
dovecot-mysql.x86_64                 1:2.0.9-2.el6_1.1         base             
freeradius-mysql.x86_64              2.1.10-5.el6              base             
libdbi-dbd-mysql.x86_64              0.8.3-5.1.el6             base             
mod_auth_mysql.x86_64                1:3.0.0-11.el6_0.1        base             
mysql.x86_64                         5.1.61-1.el6_2.1          updates          
mysql-bench.x86_64                   5.1.61-1.el6_2.1          updates          
mysql-connector-java.x86_64          1:5.1.12-2.el6            base

删除mysql-libs

[root@localhost ~]# yum remove mysql-libs



  • 打赏
  • 点赞
  • 收藏
  • 分享
共有 人打赏支持
粉丝 38
博文 386
码字总数 12168
×
Carl_
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: