加载中
第二个错误的原因应该是,如果右键运行的话,等同于直接运行jar包,需要tomcat提供的embedded container来启动整个项目。如果添加了<scope>provided</scope>,那么就不会包含这个,所以就报错了。但是在Eclipse的项目中却不会发生这个问题,IDEA就会😨
@Barret_Guo
刚来新公司在导入项目的过程当中 遇到的一个下坑 。。做简单的纪录 。。。 项目是用springboot 然后一看是...
33号小人物 2016/04/08 15:07 回答了问题: 控制器中非Action方法的AOP拦截
嗯嗯,我之前也使用过业务层的AOP,效果很好。就是对控制层中,非Action的AOP不知道怎么处理。我试试将processInMsg方法部分都抽离成业务层吧。
@33号小人物
@JFinal 你好,想跟你请教个问题:如何针对MsgController中非action的方法进行AOP拦截,例...
33号小人物 2016/04/07 16:20 回答了问题: 关于JFinal2.2中I18nInterceptor的问题

http://my.oschina.net/u/1793377/blog/654594

以上的是我的应用分享哈~

@33号小人物
@JFinal 你好,想跟你请教个问题:public void configInterceptor(Interce...
33号小人物 2015/09/23 11:35 评论了博客:关于JFinal中Jetty的类加载器问题
谢谢zhan大神的支持和鼓励 。其实我几乎所有的包都用Maven管理了,包括Jetty,但是ServletContextListener是属于Web容器的东西,它的加载会默认使用WebAppClassLoader,而其他的jar由于不在WEB-INF/lib下,就会使用系统类加载器AppClassLoader。
@33号小人物
1、问题描述首先是我遇到的问题现象是:前文1 前文2 前文3 前文4经过一个星期得顺藤摸瓜,最后找到了问题得根源是...
用这个方法是可以解决问题,避免了ClassLoader不一致的问题。不过最后我找到了问题的根源,就是JFinal-1.9的jar包放在maven下,而没有直接放在WEB-INF/lib下,所以导致了WebAppClassLoader找不到相应的类,而在AppClassLoader中加载了。
@33号小人物
前文1 前文2 前文3 以下是定时器初始化的代码,使用的是ServletContextListener:publi...
我补充了一些日志,分别在启动运行main的时候,定时器初始化的时候,configPlugin的时候和定时任务执行的时候的ClassLoader。对比两个工程,问题就出在调用configPlugin时,使用的ClassLoader是AppClassLoader,而不是WebAppClassLoader。
@33号小人物
前文1 前文2 现在终于找到根源了,在使用启动JFinalConfig中,查看到的ClassLoader为:Con...
在我另外一个同样使用定时线程的项目中,JFinalConfig启动时使用的却是WebAppClassLoader,所以我才认为这个定时线程没有影响@… @
@33号小人物
前文1 前文2 现在终于找到根源了,在使用启动JFinalConfig中,查看到的ClassLoader为:Con...
回复 @JFinal : 在我另外一个相类似的项目中,同样的代码却可以正常运行,唯一的区别是,出问题的项目的代码被我拆成了两个项目,但是出问题的项目其他功能都正常,就是这个定时任务出问题。
@33号小人物
前文再续:http://www.oschina.net/question/1793377_251436 @JFin...
回复 @JFinal : 我在程序里没有使用ClassLoader,就是直接调用Model子类的对象。通过定时任务第一次调用getClass()时,会获取到一个比插件初始化时,更早的Model对象(根据ID判断)。而当通过调用Controller,再去调用Model对象的时候,获取到的Model对象的ID,就是插件初始化时,Model对象的ID。
@33号小人物
前文再续:http://www.oschina.net/question/1793377_251436 @JFin...
配置的截图我已经补充上了。而且,我是第一次调用的时候不成功,以后的每次调用的都没问题。
@33号小人物
前文再续:http://www.oschina.net/question/1793377_251436 @JFin...
在debug中看到映射Map中是有数据的
@33号小人物
前文再续:http://www.oschina.net/question/1793377_251436 @JFin...
回复 @JFinal : 我的配置也是正常的,但是发现了新的现象:http://www.oschina.net/question/asked?id=2132322
@33号小人物
@JFinal 你好,想跟你请教个问题:我在执行一个定时任务的时候,需要对Model对象进行插入记录的操作,但是出...

没有更多内容

加载失败,请刷新页面

返回顶部
顶部