阿里云服务器centos6.3进行php升级(从5.3.3 -> 5.5.8)

2014/09/01 18:01
阅读数 523

背景:

准备使用laravel框架(http://laravel.com),但是阿里云服务器上的php版本为 5.5.3,laravel的系统要求是 php版本 > 5.3.7.

问题:

使用 yum update-check,结果 当前 centos上的源的php版本还是5.5.3,所以决定换个源;

步骤:

1、参考:http://www.rackspace.com/knowledge_center/article/installing-rhel-epel-repo-on-centos-5x-or-6x,找到源,

wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm

wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm

sudo rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm

然后查看源:

$ ls -1 /etc/yum.repos.d/epel* /etc/yum.repos.d/remi.repo

/etc/yum.repos.d/epel.repo

/etc/yum.repos.d/epel-testing.repo

/etc/yum.repos.d/remi.repo

2、配置

sudo vim /etc/yum.repos.d/remi.repo

设置 enabled 选项都是 1

3、安装

yum –enablerepo=remi update php* mysql*  

4、done


展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部