文档章节

.NET Framework 4.0不能用sqlite的问题解决方法

宿命panthers
 宿命panthers
发布于 2016/01/18 17:53
字数 585
阅读 165
收藏 3

这是因为.NET Framework 4.0中把版本号全部统一成4.0了,而这个SQLite provider是.NET 2.0的。

解决方法是在app.config的configuration节点下加入以下节点:


<startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup>

我的原来是这样的

<startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup>

以下是网上找的资料,比较详细的分析(http://www.poluoluo.com/jzxy/201305/207264.html)

查阅了相关资料,stackoverflow.com上建议在config文件中增加配置:

<startup useLegacyV2RuntimeActivationPolicy="true"> 
<supportedRuntime version="v4.0"/> 
</startup>

MSDN上也对此方法进行了阐述,参见http://msdn.microsoft.com/en-us/library/bbx34a2h(VS.100).aspx

但是使用此方法编译后问题仍然没有解决,但是问题可以明确锁定为.net runtime环境的问题了。

<startup useLegacyV2RuntimeActivationPolicy="true">
<supportedRuntime version="v4.0"/>
<requiredRuntime version="v4.0.30319" />
</startup>

再次运行,问题解决。这下需要了解是什么原因造成的?
supportedRuntime标签用来 具体说明应用程序支持的是哪个.framework运行时的版本;
requiredRuntime标签用来 具体说明应用程序只支持1.0版本的公用语言运行时间。如果使用1.1版本或者后面的版本来编译,应用程序必须使用<supportedRuntime>元素;
注意:
<supportedRuntime>必须通过1.1版本或后面的版本而编译的应用程序来使用。只支持1.0版本的运行时间的应用程序必须使用<requiredRuntime>。

再次查阅CLR Runtime版本的相关资料,引用以下CLR运行规则和各版本间关系汇总表格,如下:
规则:
1. CLR4.0及以上版本编译的应用程序总是运行在应用程序所被编译的CLR版本上;
2. CLR4.0以下版本编译的应用程序优先运行在被编译的CLR版本上,如果此版本不存在,则运行最新的小于CLR4.0的版本; 
汇总如下:

至此我们就能很清楚的搞清各个CLR版本之间的联系了。

总结:微软每次版本升级都会造成一些新的问题的出现,早年从CLRv1.0到CLRv2.0曾经也造成很多的困惑,可能也是由于过大的组织造成不能面面俱到吧,希望在今后的版本升级中能真正做到无缝的版本联接。


© 著作权归作者所有

上一篇: 模拟登录
下一篇: c#显示dwf文件
宿命panthers
粉丝 5
博文 29
码字总数 15608
作品 0
青岛
程序员
私信 提问
受 SQLite 多年青睐,C 语言到底好在哪儿?

SQLite 近日发表了一篇博文,解释了为什么多年来 SQLite 一直坚持用 C 语言来实现,以下是正文内容: C 语言是最佳选择 从2000年5月29日发布至今,SQLite 一直都是用 C 语言实现。C 一直是实...

王练
2018/08/31
5.3K
31
SQLite 的 CodeFirst 模式

目录 问题描述 解决方案 安装依赖包 修改程序配置 App.config 创建模型对象 Person.cs 创建数据上下文 PersonDbContext.cs 主程序调用 Program.cs 注意事项 相关参考 目前 EF 是 .NET 平台下...

hippieZhou
2018/08/04
0
0
安卓应用安全指南 4.5.3 使用 SQLite 高级话题

安卓应用安全指南 4.5.3 使用 SQLite 高级话题 原书:Android Application Secure Design/Secure Coding Guidebook 译者:飞龙 协议:CC BY-NC-SA 4.0 4.5.3.1 在 SQL 语句的断言中使用通配符...

apachecn_飞龙
2018/03/22
0
0
解决网站使用sqlite时并发问题的一个经验

前几天在CSDN上看到有人使用sqlite+tomcat实现一个web应用,并发操作引起数据库锁定,在发帖求助。这才想起自己以前做的一个web应用也有相同问题,顺便把自己解决方法写下来,供大家参考。 ...

向前看软件
2011/11/08
0
1
SQLite 指南之FAQ(中文)

1. 如何创建自增字段? 2. SQLite 支持哪些数据类型? 3. 为什么能向 SQLite 数据库的整型字段中插入字符串? 4. 为什么 SQLite 认为表达式 '0'=='00' 为真? 5. 为什么 SQLite 不允许在同一...

晨曦之光
2012/04/12
641
0

没有更多内容

加载失败,请刷新页面

加载更多

Cesium中级4 - 空间数据可视化(二)

Cesium中文网:http://cesiumcn.org/ | 国内快速访问:http://cesium.coinidea.com/ Viewer中的Entity功能 让我们看看Viewer为操作entities提供出来的功能函数。 选中和描述 点击Viewer中的e...

Cesium中文网
3分钟前
0
0
Linux-CentOS7 安装VMware Workstation

Linux-CentOS7 安装VMware Workstation 太极之道关注0人评论1605人阅读2018-10-17 14:36:22 Linux-CentOS7 安装VMware Workstation 12 1、下载VMware 衔接地址 http://www.vmware.com/produc......

linjin200
5分钟前
0
0
centos7.5 部署flask+nginx+uwsgi+python3

centos7.5 部署flask+nginx+uwsgi+python3 ## uwsgi [uwsgi] master = true max-requests = 6000 processes = 6 threads = 6 chmod-socket = 664 thunder-lock = true buffer-size = 32768 #......

丁典
9分钟前
0
0
BigData NoSQL —— ApsaraDB HBase数据存储与分析平台概览

一、引言 时间到了2019年,数据库也发展到了一个新的拐点,有三个明显的趋势: 越来越多的数据库会做云原生(CloudNative),会不断利用新的硬件及云本身的优势打造CloudNative数据库,国内以阿...

阿里云官方博客
14分钟前
0
0
好代码是什么样的?

简评: 好代码是什么样的?相信不同的人会有不同的看法,正如「一千个读者,就有一千个哈姆雷特」,关键在于你有没有自己的标准。 这篇文章是我个人很喜欢的一家公司 - Atomic Spin 的 blog...

极光推送
15分钟前
2
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部