java override error
java override error
moreThink 发表于2年前
java override error
  • 发表于 2年前
  • 阅读 15
  • 收藏 1
  • 点赞 1
  • 评论 0
摘要: java override error

在搭建maven项目时如果项目识别不了 @override

类似The method *** of type *** must override a superclass method

那么可能是你的java compiler 版本小于1.6,因为1.6之前的版本不识别@override。

方法一:只需要在pom文件中加上下面的plugin就可以指定项目使用的java 编译版本了。

<plugin>
    <artifactId>maven-compiler-plugin</artifactId>
    <configuration>
     <source>1.6</source>
     <target>1.6</target>
     <encoding>UTF-8</encoding>
    </configuration>
   </plugin>

 

方法二:手动将window->preferences->java-compiler中的Compiler compliance level修改为6.0。

 

共有 人打赏支持
粉丝 3
博文 38
码字总数 14946
×
moreThink
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: