记一次dubbo切换nacos为注册中心,版本问题踩坑

原创
07/07 15:50
阅读数 1.3K

公司基于架构演进考虑,原来采用zookeeper为注册中心的dubbo服务,要改为nacos为注册中心。基于不使用最新版的考虑,使用了dubbo2.7.6版本,然后在本地开发时消费者死活都无法调用到提供者,启动消费者端服务就报“No provider available for the service”,纠结了一天多时间,然后尝试着降低dubbo版本到2.7.3版本,发现解决了。

后面使用2.7.7版本验证也是可以的,特踩坑记录。

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
在线直播报名
返回顶部
顶部