文档章节

mysql 客户端(workbench)的安装 

树上的风筝
 树上的风筝
发布于 2016/04/03 09:04
字数 2320
阅读 741
收藏 3

一、先学习一下小知识

        在ubuntu上查看mysql的版本大约有三种方式。

        第一种:在mysql里找。

                        登录上mysql,然后输入命令status,红色标识是版本信息,如下:

                        mysql>status;

                                                              

                        Connection id:        7
                        Current database:    
                        Current user:        root@localhost
                        SSL:            Not in use
                        Current pager:        stdout
                        Using outfile:        ''
                         Using delimiter:    ;                          

                        Protocol version:    10
                                Connection:        Localhost via UNIX socket
                                Server characterset:    latin1
                                    Db     characterset:    latin1
                                Client characterset:    utf8
                                Conn.  characterset:    utf8
                                UNIX socket:        /var/run/mysqld/mysqld.sock
                                Uptime:            25 min 13 sec
            第二种方法:登录上mysql,输入sql 语句select version(),如下所示

                                mysql>select version();

    +-------------------------+
| version()               |
+-------------------------+
| 5.6.28-0ubuntu0.15.10.1 |
+-------------------------+
1 row in set (0.00 sec)

            第三种方法:在help帮助里查找,命令如下:mysql --help |grep Distrib

            pkx@pkx-Aspire-V5-452G:~$ mysql --help |grep Distrib

            mysql  Ver 14.14 Distrib 5.6.28, for debian-linux-gnu (x86_64) using  EditLine wrapper

这几种方式都可以查看mysql的版本。顺便把ubuntu的版本也查看了。

 第四种、 在命令行中输入命令 mysql -V ,我的不行,这种大家在本机自己测试把。


接下来不说废话了,安装workbench

    一、官网下载Mysql Workbench

         http://dev.mysql.com/get/Downloads/MySQLGUITools/mysql-workbench-community-6.3.6-1ubu1510-amd64.deb

            wget url   url 是下载地址

二、安装解压

            我的安装包安装在 /media/pkx/xuexi_1/MysqlWorkBench/目录下

                sudo dpkg -i mysql-workbench-community-6.3.6-1ubu1510-amd64.deb  -c /media/pkx/xuexi_1/MysqlWorkBench/

        碰到如下问题:

    (正在读取数据库 ... 系统当前共安装有 215568 个文件和目录。)
正准备解包 mysql-workbench-community-6.3.6-1ubu1510-amd64.deb  ...
正在将 mysql-workbench-community (6.3.6-1ubu1510) 解包到 (6.3.6-1ubu1510) 上 ...
dpkg (子进程):为了使dpkg正常工作,管理目录必须在安装目录中
dpkg:警告:子进程 旧的 post-removal 脚本 返回错误状态 2
dpkg: 现在尝试使用新软件包所带的脚本...
dpkg (子进程):为了使dpkg正常工作,管理目录必须在安装目录中
dpkg: 处理归档 mysql-workbench-community-6.3.6-1ubu1510-amd64.deb (--install)时出错:
 子进程 新的 post-removal 脚本 返回错误状态 2
dpkg (子进程):为了使dpkg正常工作,管理目录必须在安装目录中
dpkg:清理时出错:
 子进程 新的 post-removal 脚本 返回错误状态 2
在处理时有错误发生:
 mysql-workbench-community-6.3.6-1ubu1510-amd64.deb
root@pkx-Aspire-V5-452G:/media/pkx/xuexi/dev.mysql.com/get/Downloads/MySQLGUITools# sudo dpkg -i  mysql-workbench-community-6.3.6-1ubu1510-amd64.deb  (正在读取数据库 ... 系统当前共安装有 215568 个文件和目录。)
正准备解包 mysql-workbench-community-6.3.6-1ubu1510-amd64.deb  ...
正在将 mysql-workbench-community (6.3.6-1ubu1510) 解包到 (6.3.6-1ubu1510) 上 ...
dpkg: 依赖关系问题使得 mysql-workbench-community 的配置工作不能继续:
 mysql-workbench-community 依赖于 libctemplate2v5;然而:
  未安装软件包 libctemplate2v5。
 mysql-workbench-community 依赖于 libgeos-c1v5 (>= 3.4.2);然而:
  未安装软件包 libgeos-c1v5。
 mysql-workbench-community 依赖于 libgif4 (>= 4.1.4);然而:
  未安装软件包 libgif4。
 mysql-workbench-community 依赖于 libgtkmm-2.4-1v5 (>= 1:2.24.0);然而:
  未安装软件包 libgtkmm-2.4-1v5。
 mysql-workbench-community 依赖于 libhdf4-0-alt;然而:
  未安装软件包 libhdf4-0-alt。
 mysql-workbench-community 依赖于 libnetcdf7 (>= 4.0.1);然而:
  未安装软件包 libnetcdf7。
 mysql-workbench-community 依赖于 libodbc1 (>= 2.3.1);然而:
  未安装软件包 libodbc1。
 mysql-workbench-community 依赖于 libpcrecpp0v5 (>= 7.7);然而:
  未安装软件包 libpcrecpp0v5。
 mysql-workbench-community 依赖于 libpq5;然而:
  未安装软件包 libpq5。
dpkg: 处理软件包 mysql-workbench-community (--install)时出错:
 依赖关系问题 - 仍未被配置
在处理时有错误发生:
 mysql-workbench-community


解决方案:

如下:

    安装前先更新操作:

      1、sudo apt-get update
               sudo apt-get upgrade

    然后这一步后还会提示缺依赖包,

    2、sudo apt-get  -f install

    这样就将依赖包添加上了,如下图所示的执行代码

    root@pkx-Aspire-V5-452G:/media/pkx/xuexi/dev.mysql.com/get/Downloads/MySQLGUITools# sudo apt-get -f  install  
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
正在更正依赖关系... 完成
将会安装下列额外的软件包:
  libctemplate2v5 libgeos-3.5.0 libgeos-c1v5 libgfortran3 libgif4
  libgtkmm-2.4-1v5 libhdf4-0-alt libhdf5-10 libnetcdf7 libodbc1 libpcrecpp0v5
  libpq5 libxerces-c3.1 libzip4 odbcinst odbcinst1debian2 python-ecdsa
  python-paramiko
建议安装的软件包:
  libhdf4-doc libhdf4-alt-dev hdf4-tools libnetcdf4 libmyodbc odbc-postgresql
  tdsodbc unixodbc-bin
下列【新】软件包将被安装:
  libctemplate2v5 libgeos-3.5.0 libgeos-c1v5 libgfortran3 libgif4
  libgtkmm-2.4-1v5 libhdf4-0-alt libhdf5-10 libnetcdf7 libodbc1 libpcrecpp0v5
  libpq5 libxerces-c3.1 libzip4 odbcinst odbcinst1debian2 python-ecdsa
  python-paramiko
升级了 0 个软件包,新安装了 18 个软件包,要卸载 0 个软件包,有 3 个软件包未被升级。
有 7 个软件包没有被完全安装或卸载。
需要下载 4,545 kB 的软件包。
解压缩后会消耗掉 20.9 MB 的额外空间。
您希望继续执行吗? [Y/n] y
获取:1 http://cn.archive.ubuntu.com/ubuntu/ wily/universe libctemplate2v5 amd64 2.2-5ubuntu1 [144 kB]
获取:2 http://cn.archive.ubuntu.com/ubuntu/ wily/universe libgeos-3.5.0 amd64 3.5.0-1build1 [477 kB]
获取:3 http://cn.archive.ubuntu.com/ubuntu/ wily/universe libgeos-c1v5 amd64 3.5.0-1build1 [52.6 kB]
获取:4 http://cn.archive.ubuntu.com/ubuntu/ wily/main libgif4 amd64 4.1.6-11 [28.6 kB]
获取:5 http://cn.archive.ubuntu.com/ubuntu/ wily/main libgtkmm-2.4-1v5 amd64 1:2.24.4-2 [671 kB]
获取:6 http://cn.archive.ubuntu.com/ubuntu/ wily/universe libhdf4-0-alt amd64 4.2.10-3.2 [264 kB]
获取:7 http://cn.archive.ubuntu.com/ubuntu/ wily/main libgfortran3 amd64 5.2.1-22ubuntu2 [258 kB]
获取:8 http://cn.archive.ubuntu.com/ubuntu/ wily/universe libhdf5-10 amd64 1.8.15-patch1+docs-4 [1,034 kB]
获取:9 http://cn.archive.ubuntu.com/ubuntu/ wily/universe libnetcdf7 amd64 1:4.4.0~rc2-1build1 [275 kB]获取:10 http://cn.archive.ubuntu.com/ubuntu/ wily/main libodbc1 amd64 2.3.1-3 [176 kB]
获取:11 http://cn.archive.ubuntu.com/ubuntu/ wily-updates/main libpcrecpp0v5 amd64 2:8.35-7.1ubuntu1.3 [15.4 kB]
获取:12 http://cn.archive.ubuntu.com/ubuntu/ wily-updates/main libpq5 amd64 9.4.6-0ubuntu0.15.10 [76.9 kB]
获取:13 http://cn.archive.ubuntu.com/ubuntu/ wily-updates/universe libxerces-c3.1 amd64 3.1.1-5.1+deb8u1build0.15.10.1 [843 kB]
获取:14 http://cn.archive.ubuntu.com/ubuntu/ wily/universe libzip4 amd64 1.0.1-0ubuntu1 [36.3 kB]
获取:15 http://cn.archive.ubuntu.com/ubuntu/ wily/main odbcinst amd64 2.3.1-3 [13.1 kB]
获取:16 http://cn.archive.ubuntu.com/ubuntu/ wily/main odbcinst1debian2 amd64 2.3.1-3 [40.6 kB]
获取:17 http://cn.archive.ubuntu.com/ubuntu/ wily/main python-ecdsa all 0.13-2 [34.0 kB]
获取:18 http://cn.archive.ubuntu.com/ubuntu/ wily/main python-paramiko all 1.15.2-1 [106 kB]
下载 4,545 kB,耗时 12秒 (355 kB/s)                                            
正在选中未选择的软件包 libctemplate2v5。
(正在读取数据库 ... 系统当前共安装有 215575 个文件和目录。)
正准备解包 .../libctemplate2v5_2.2-5ubuntu1_amd64.deb  ...
正在解包 libctemplate2v5 (2.2-5ubuntu1) ...
正在选中未选择的软件包 libgeos-3.5.0。
正准备解包 .../libgeos-3.5.0_3.5.0-1build1_amd64.deb  ...
正在解包 libgeos-3.5.0 (3.5.0-1build1) ...
正在选中未选择的软件包 libgeos-c1v5。
正准备解包 .../libgeos-c1v5_3.5.0-1build1_amd64.deb  ...
正在解包 libgeos-c1v5 (3.5.0-1build1) ...
正在选中未选择的软件包 libgif4:amd64。
正准备解包 .../libgif4_4.1.6-11_amd64.deb  ...
正在解包 libgif4:amd64 (4.1.6-11) ...
正在选中未选择的软件包 libgtkmm-2.4-1v5:amd64。
正准备解包 .../libgtkmm-2.4-1v5_1%3a2.24.4-2_amd64.deb  ...
正在解包 libgtkmm-2.4-1v5:amd64 (1:2.24.4-2) ...
正在选中未选择的软件包 libhdf4-0-alt。
正准备解包 .../libhdf4-0-alt_4.2.10-3.2_amd64.deb  ...
正在解包 libhdf4-0-alt (4.2.10-3.2) ...
正在选中未选择的软件包 libgfortran3:amd64。
正准备解包 .../libgfortran3_5.2.1-22ubuntu2_amd64.deb  ...
正在解包 libgfortran3:amd64 (5.2.1-22ubuntu2) ...
正在选中未选择的软件包 libhdf5-10:amd64。
正准备解包 .../libhdf5-10_1.8.15-patch1+docs-4_amd64.deb  ...
正在解包 libhdf5-10:amd64 (1.8.15-patch1+docs-4) ...
正在选中未选择的软件包 libnetcdf7。
正准备解包 .../libnetcdf7_1%3a4.4.0~rc2-1build1_amd64.deb  ...
正在解包 libnetcdf7 (1:4.4.0~rc2-1build1) ...
正在选中未选择的软件包 libodbc1:amd64。
正准备解包 .../libodbc1_2.3.1-3_amd64.deb  ...
正在解包 libodbc1:amd64 (2.3.1-3) ...
正在选中未选择的软件包 libpcrecpp0v5:amd64。
正准备解包 .../libpcrecpp0v5_2%3a8.35-7.1ubuntu1.3_amd64.deb  ...
正在解包 libpcrecpp0v5:amd64 (2:8.35-7.1ubuntu1.3) ...
正在选中未选择的软件包 libpq5:amd64。
正准备解包 .../libpq5_9.4.6-0ubuntu0.15.10_amd64.deb  ...
正在解包 libpq5:amd64 (9.4.6-0ubuntu0.15.10) ...
正在选中未选择的软件包 libxerces-c3.1:amd64。
正准备解包 .../libxerces-c3.1_3.1.1-5.1+deb8u1build0.15.10.1_amd64.deb  ...
正在解包 libxerces-c3.1:amd64 (3.1.1-5.1+deb8u1build0.15.10.1) ...
正在选中未选择的软件包 libzip4:amd64。
正准备解包 .../libzip4_1.0.1-0ubuntu1_amd64.deb  ...
正在解包 libzip4:amd64 (1.0.1-0ubuntu1) ...
正在选中未选择的软件包 odbcinst。
正准备解包 .../odbcinst_2.3.1-3_amd64.deb  ...
正在解包 odbcinst (2.3.1-3) ...
正在选中未选择的软件包 odbcinst1debian2:amd64。
正准备解包 .../odbcinst1debian2_2.3.1-3_amd64.deb  ...
正在解包 odbcinst1debian2:amd64 (2.3.1-3) ...
正在选中未选择的软件包 python-ecdsa。
正准备解包 .../python-ecdsa_0.13-2_all.deb  ...
正在解包 python-ecdsa (0.13-2) ...
正在选中未选择的软件包 python-paramiko。
正准备解包 .../python-paramiko_1.15.2-1_all.deb  ...
正在解包 python-paramiko (1.15.2-1) ...
正在处理用于 man-db (2.7.4-1) 的触发器 ...
正在设置 mime-support (3.58ubuntu1) ...
正在设置 shared-mime-info (1.3-1) ...
正在设置 bamfdaemon (0.5.2~bzr0+15.10.20150627.1-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
正在设置 desktop-file-utils (0.22-1ubuntu3) ...
正在设置 gnome-menus (3.13.3-6ubuntu1) ...
正在设置 hicolor-icon-theme (0.15-0ubuntu1) ...
正在设置 libctemplate2v5 (2.2-5ubuntu1) ...
正在设置 libgeos-3.5.0 (3.5.0-1build1) ...
正在设置 libgeos-c1v5 (3.5.0-1build1) ...
正在设置 libgif4:amd64 (4.1.6-11) ...
正在设置 libgtkmm-2.4-1v5:amd64 (1:2.24.4-2) ...
正在设置 libhdf4-0-alt (4.2.10-3.2) ...
正在设置 libgfortran3:amd64 (5.2.1-22ubuntu2) ...
正在设置 libhdf5-10:amd64 (1.8.15-patch1+docs-4) ...
正在设置 libnetcdf7 (1:4.4.0~rc2-1build1) ...
正在设置 libodbc1:amd64 (2.3.1-3) ...
正在设置 libpcrecpp0v5:amd64 (2:8.35-7.1ubuntu1.3) ...
正在设置 libpq5:amd64 (9.4.6-0ubuntu0.15.10) ...
正在设置 libxerces-c3.1:amd64 (3.1.1-5.1+deb8u1build0.15.10.1) ...
正在设置 libzip4:amd64 (1.0.1-0ubuntu1) ...
正在设置 python-ecdsa (0.13-2) ...
正在设置 python-paramiko (1.15.2-1) ...
正在设置 odbcinst (2.3.1-3) ...
正在设置 odbcinst1debian2:amd64 (2.3.1-3) ...
正在设置 mysql-workbench-community (6.3.6-1ubu1510) ...
正在处理用于 libc-bin (2.21-0ubuntu4.1) 的触发器 ...

    3、在尝试安装mysql-workbench

        dpkg -i  mysql-workbench-community-6.3.6-1ubu1510-amd64.deb*
     这样就可以了。

4、启动mysql-workbench

       pkx@pkx-Aspire-V5-452G:/usr/bin$ mysql-workbench
    不截图了,应该大家都能直到什么是启动成功

  完美。


                        


© 著作权归作者所有

上一篇: Linux 常用命令
下一篇: 安装和卸载mysql
树上的风筝
粉丝 1
博文 38
码字总数 20210
作品 0
朝阳
程序员
私信 提问
加载中

评论(1)

暗夜之虎
暗夜之虎
sudo apt-get install mysql-workbencj
mysql-workbench连接时闪退

安装环境是centos6.5; mysql版本5.7.12; mysql-workbench版本6.3.6 新建连接后Test Connection显示成功,但点击选项卡正式连接时就闪退了,workbench日志最后显示的是[AutoCCache]:Initia...

409996615
2016/06/01
1K
1
MySQL各版本的区别第一个MySQLCommunityServer,这个不要钱第二个MySQLE

MySQL各版本的区别 第一个 MySQL Community Server,这个不要钱! 第二个 MySQL Enterprise 这个要掏钱,不过可以打电话咨询问题,也就是电话技术支持。 第三个 MySQL Cluster,这个单独是没...

Airship
2015/01/15
230
0
Ubuntu下安装MysqlWorkBench

1、先下载workBench https://dev.mysql.com/downloads/file/?id=455790 2、先执行命令: sudo dpkg -i mysql-workbench-community-6.2.5-1ubu1404-amd64.deb 安装 安装的时候报错: liang@li......

winter199
2017/11/23
0
0
MySQL Workbench 8.0 稳定版(8.0.12)正式发布

MySQL Workbench 8.0 稳定版(版本号 8.0.12)已正式发布。 下载地址 >>> https://dev.mysql.com/downloads/workbench/8.0.html 值得关注的更新 不再支持在 MySQL Workbench 6.3 之前版本保存......

局长
2018/07/29
8.3K
22
MySQL各个版本的区别

MySQL 的官网下载地址:http://www.mysql.com/downloads/ 在这个下载界面会有几个版本的选择。 1. MySQL Community Server 社区版本,开源免费,但不提供官方技术支持。 2. MySQL Enterpris...

hisense20112784
2017/06/08
0
0

没有更多内容

加载失败,请刷新页面

加载更多

ES6

ES6:不改变原理的基础上,让API变得更简单 一、let:代替var用于声明变量 1、var的缺点: (1)声明提前 (2)没有块级作用域 2、let的优点: (1)组织了申明提前 (2)让let所在的块({}),...

wytao1995
今天
3
0
kubernetes 环境搭建 —— minikube

创建集群 minikube start 搭建好 k8s 集群后,可以查看集群的状态以及部署应用。主要用到的是 k8s 的 api,这通常需借助于 kutectl 命令行工具 基本操作 kubectl versionkubectl cluster-i...

lemos
今天
9
0
关于js混淆与反混淆还原操作

使用js的混淆加密,其目的是为了保护我们的前端代码逻辑,对应一些搞技术吃饭的公司来说,为了防止被竞争对手抓取或使用自己的代码,就会考虑如何加密,或者混淆js来达到代码保护。 1、为什么...

开源oschina
今天
11
0
用盛金公式解三次方程(ansi c版)

/* cc cubic.c -lm gcc cubic.c -lm Shengjin's Formulas Univariate cubic equation aX ^ 3 + bX ^ 2 + cX + d = 0, (a, b, c, d < R, and a!= 0). Multiple root disc......

wangxuwei
今天
9
0
JBolt开发平台入门(16)- 弹出Dialog显示指定区域的html内容

在JBolt里,有个主从表Demo。 子表中除了普通的table显示,还有其它从表显示形式 比如下方案例:是针对一个升级管理子表中存放版本的changelog富文本信息。 需求是点击左上角的弹出查看按钮,...

山东-小木
今天
46
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部