文档章节

编译安装php5.5

RoyeeD
 RoyeeD
发布于 2014/09/09 15:57
字数 190
阅读 73
收藏 0

tar -zvxf php-5.5.0.tar.gz
cd php-5.5.0
./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php/etc --enable-fpm --enable-sysvsem --enable-sockets --enable-pcntl --enable-mbstring --enable-mysqlnd --enable-opcache --enable-shmop  --enable-zip --enable-ftp --enable-gd-native-ttf --enable-wddx --enable-soap

make && make install
拷贝一份正式的php-fpm.conf

更多选项... ./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php/etc --enable-fpm --enable-sysvsem --enable-sockets --enable-pcntl --enable-mbstring --enable-mysqlnd --enable-opcache --enable-shmop  --enable-zip --with-mcrypt=/usr/local/libmcrypt/ --with-zlib=/usr/local/zlib/ --with-curl=/usr/local/curl/ --with-pcre-dir=/usr/local/pcre/ --with-t1lib=/usr/local/tlib/ --with-pdo-mysql=/usr/ --with-fpm-user=www --with-fpm-group=www

cp /usr/local/php/etc/php-fpm.conf.default /usr/local/php/etc/php-fpm.conf


启动PHP:
/usr/local/php/sbin/php-fpm




config 第二种

./configure --prefix=/usr/local/php \

--with-libxml-dir=/usr/include/libxml2 \

--with-config-file-path=/usr/local/php/etc/ \

--with-mysql=mysqlnd \

--with-mysqli=mysqlnd \

--with-gd \

--enable-gd-native-ttf \

--with-zlib \

--with-mcrypt \

--with-pdo-mysql=/usr/local/mysql \

--enable-shmop \

--enable-soap \

--enable-sockets \

--enable-wddx \

--enable-zip \

--with-xmlrpc \

--enable-fpm \

--enable-mbstring \

--with-zlib-dir \

--with-bz2 \

--with-curl \

--enable-exif \

--enable-ftp \

--with-jpeg-dir=/usr/lib64 \

--with-png-dir=/usr/lib64 \

--with-freetype-dir=/usr/lib64 \

--with-iconv \

--enable-xml \

--enable-bcmath \

--enable-sysvsem \

--enable-inline-optimization \

--with-curl \

--enable-mbregex \

--with-openssl \

--enable-pcntl \

--with-gettext \

--enable-opcache  \

--enable-session \

--disable-fileinfo


--disable-fileinfo 是内存不满1G时使用

本文转载自:

上一篇: nginx 编译安装
RoyeeD
粉丝 2
博文 10
码字总数 4191
作品 0
闵行
程序员
私信 提问
ubuntu通过ppa源安装php5.4或php5.5

Ppa-purge: 是一个ppa源扩展工具,它可以帮助你禁用指定的 ppa 源并重新安装官方源中的软件包,有时候你通过 PPA 安装了某软件的最新版本,但感觉不是很稳定,通过它就可以还源到官方源中的稳...

贪睡猫仙mosen
2014/06/16
340
0
安装php工作在fast-cgi模式并用xcache加速

OS: centos6.7 软件版本:apache2.4,mysql5.5,php5.5,xcache3.2 确保已经安装的包组: Development Tools Server Platform Development Desktop Platform Development 一 安装mysql的通用二进......

码上有春天
2016/08/28
32
0
php中的脚本加速扩展opcache (1)

今儿在azure里装php5.5.4得瑟,发现原先php5.4、php5.3中的zend guard laoder以及php5.2中的Zend Optimizer均不能再用,一直很喜欢用的eaccelerator也悲剧了,编译的时候直接提示错误。 没办...

lg2045
2015/04/27
549
0
Nginx/Apache版PHP5.5系列UPUPW5.0发布

UPUPW说明: 本次N5.0/A5.0集成的是PHP官方最新发布的PHP5.5系列版本,由于很多PHP程序都是在此之前开发的所以不保证每个程序都能完美兼容PHP5.5,经UPUPW初步测试Discuz X3和PHPwind 9.0在P...

UPUPW
2013/07/15
2K
16
Ubuntu 下 nginx , php , mysql 和 golang 的简单安装

我是搞php出身,自然安装lnmp是常规技能。以前的手段还是lnmp安装包,比如军哥的lnmp1.0。随着php和mysql的更新,大多数一键安装都开始版本老化,更新困难的问题。因此,重新研究了一下Ubunt...

傅小黑
2014/02/19
806
0

没有更多内容

加载失败,请刷新页面

加载更多

nginx+tomcat配置https

1、nginx配置https和【proxy_set_header X-Forwarded-Proto $scheme;】 2、java代码: String basePath = request.getScheme() + "://" + request.getServerName() + ":" + request.getServe......

perofu
21分钟前
4
0
必看的Linux系统新手进阶老手心得

不知道从什么时候起,linux这个话题变得越来越普及,成为大家经常讨论的话题。无论在网络上还是实际生活中,竟然很多人都在纠结学习linux的问题。网络上给的答案千千万万,而却还有很多人踌躇...

Linux就该这么学
24分钟前
4
0
Spring Boot 配置元数据指南

1. 概览 在编写 Spring Boot 应用程序时,将配置属性映射到 Java bean 上是非常有用的。但是,记录这些属性的最好方法是什么呢? 在本教程中,我们将探讨 Spring Boot Configuration Proces...

liululee
27分钟前
3
0
foreach查找子类

$list = $menu_model -> menu_list();$parent_list = [];foreach ($list as $v){ if ($v['pid'] == 0) { $parent = $v; foreach ($list as $v1) ......

小小小壮
39分钟前
3
0
基于 HTML5 Canvas 实现的 TP-LINK 电信拓扑设备面板

前言 今天我们以真实的 TP-LINK 设备面板为模型,完成设备面板的搭建,和指示灯的闪烁和图元流动。 先来目睹下最终的实现效果:http://www.hightopo.com/demo/blog_tplink_20170511/index.h...

htdaydayup
45分钟前
4
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部