加载中
使用 IDEA + Maven + Git 快速开发 Java Web 应用

目录[-] 0. 引言 1. 使用 Git 下载源码 2. 编写 Maven 项目配置文件 3. 使用 IDEA 直接打开 Maven 项目 4. 编译源码 5. 在 IDEA 中配置 Tomcat 6. 以 Debug 方式运行应用程序 7. 在 IDEA 中对...

10个调试和排错的小建议

在空白的文本编辑器里打开一个崭新的文本,没有一行代码,出现在眼前的是一个充满了无限可能和希望的项目。可是,当数千行的代码写完之后,整个项目因为bug的出现而被压垮了,更别说添加什么...

Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead

提示Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties. 解决方法: 1.项目右键 ->android tools->Fix Pro...

Not targeting the latest versions of Android

在AndroidManifest.xml中,经常出现如下警告: Not targeting the latest versions of Android; compatibility modes apply. Consider testing and updating this version. Consult the and...

System.Data.SqlClient.SqlError: 备份集中的数据库备份与现有的 'XXX' 数据库不同。

System.Data.SqlClient.SqlError: 备份集中的数据库备份与现有的 'XXX' 数据库不同。 在sql server 2008 r2 版本中还原从sql server 2008 express备份出来的数据库时,提示上述错误。 原因如...

android 通过setalpha设置透明度 无效及3.0以下不兼容的问题

android 通过setalpha设置透明度 无效及3.0以下不兼容的问题 【1】3.0以下版本,不支持setalpha, 且不支持在xml文件中设置android:alpha = "0.5"这种方法(如果xml中设置则一律是不透明的); 【...

2015/04/29 00:40
4
Android 导入android源码有错,R.java文件不能自动生成解决方法

Unable to resolve target 'android-7' 意思就是没有找到“android_7”,这里的7不是android版本,而是API版本。 打开项目文件里的default.properties,把target=android-7改成你有的版本。 ...

2015/04/29 00:41
28
SQL Server JDBC驱动中sqljdbc和sqljdbc4区别

sqljdbc.jar 类库提供对JDBC 3.0 的支持。 sqljdbc.jar 类库要求使用 5.0 版的 Java 运行时环境 (JRE)。连接到数据库时,在 JRE 6.0 上使用 sqljdbc.jar 会引发异常。 注意: SQL Server JDB...

Eclipse反编译工具Jad及插件JadClipse配置

Jad是一个Java的一个反编译工具,是用命令行执行,和通常JDK自带的java,javac命令是一样的。不过因为是控制台运行,所以用起来不太方便。不过幸好有一个eclipse的插件JadClipse,二者结合可...

Axis,axis2,Xfire以及cxf对比

http://ws.apache.org/axis/ http://axis.apache.org/axis2/java/core/ http://xfire.codehaus.org/ http://cxf.apache.org/ axis最新的版本为April 22, 2006 axis2最新的版本为19 - Dec - ...

2015/04/29 00:42
16
Ubuntu下升级git版本(源码编译安装git)

Ubuntu自带的git是1.7的版本的,太旧了,所以想升级下,git官网上没有提供现成的安装包,所以只能源码编译了。 linux上源码编译安装Git拢共分两步: 第一步,安装编译git的依赖包 第二步,下...

Java @override报错的解决方法

背景: Myeclipse中出现@Override错误,必须删除此标志,项目才可以编译通过,但是本来这个方法就是要重写的,为什么会报错呢 原因: jdk1.5(5.0)之前这个就有,算是Bug,jdk1.6(6.0)版本...

Sql Server 2005 Express数据库导入导出功能的实现

记得以前用SqlServer 2000的时候在“右键数据库->所有任务->导入数据/导出数据”这个选项,但是最近在使用SqlServer 2005 express的时候发现居然没有“导入/导出”功能,这个让人相当郁闷。 ...

Smack和Asmack

Smack库的Android版本,虽然Smack在PC上可以工作的很好,功能也很强大,但在Android平台上有一些问题,而导致这些问题的原因是Android精简了Java的类库,以至Smack使用的部分类库在Android平台上无...

JETTY9(9.2.1)入门学习

原文:http://blog.csdn.net/guoyankun/article/details/38319689 下载的jetty-distribution-9.2.1.v20150310,算是目前为止的最新版本,jetty的版本比较多,而且各种版本有一定的差异,感觉...

2015/04/29 00:44
35
进入PE系统后找不到硬盘该怎么办?

进入PE系统后找不到硬盘该怎么办?找不到硬盘的情况通常会出现在一些新的电脑上,那么如果我们遇到这样的问题,要如何解决才好呢?现在u启动小编跟大家解释一下出现这样情况的原因和解决方法...

2015/04/29 00:39
6
配置SpringMVC返回JSON遇到的坑

坑一:官方网站下载地址不明朗,最后找了几个下载地址:http://wiki.fasterxml.com/JacksonDownload Jackson2.5下载地址:jackson2.5.0.jar 坑二:配置文件的配置信息跟jackson的版本有关。 ...

Application does not specify an API level requirement!

调试android代码的时候控制台提示“Application does not specify an API level requirement!” 说明你没有设置这个软件的最低兼容版本,在 AndroidManifest.xml中 加入: <uses-sdk android...

使用Nexus搭建Maven本地仓库

转载文章:http://www.cnblogs.com/helong/articles/2254446.html 部署环境是windowsxp 首先从 http://nexus.sonatype.rog/downloads 下载最新版的Nexus 我们可以根据个人的需求下载。里面有...

2015/04/29 00:39
107
Spring官方网站改版后的下载地址

转载地址:http://www.oschina.net/question/1184617_125940 各个版本的 Srping下载地址: http://maven.springframework.org/release/org/springframework/spring/ Spring资源下载: http:/...

没有更多内容

加载失败,请刷新页面

返回顶部
顶部