文档章节

关于新版ADT创建项目时出现appcompat_v7的问题

蜀山下的鱼
 蜀山下的鱼
发布于 2015/04/29 00:40
字数 660
阅读 16
收藏 0

原文:http://jingyan.baidu.com/article/3ea51489e04eb852e61bbaa4.html


  做Android开发的朋友最近会发现,更新ADT至22.6.0版本之后,创建新的安装项目,会出现appcompat_v7的内容。并且是创建一个新的内容就会出现。这到底是怎么回事呢?原来appcompat_v7是Google自己的一个兼容包,就是一个支持库,能让2.1以上全使用上4.0版本的界面。下面就让笔者带你慢慢走近这个问题并解决它。


  1. 首先我们打开Eclipse,新建一个Android项目,这里名字就用“test”好了,一路默认next下去,最后“Finish”完成项目的创建。

    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
  2. 2

    你会发现项目创建好后,workspace栏里除了我们创建的“test”项目,还多了一个名为“appcompat_v7”的包,而且这个包显示有错误(红色x号),而“test”包显示一个红色的感叹号。

    关于新版ADT创建项目时出现appcompat_v7的问题
  3. 3

    如果你不习惯appcompat_v7包的自动产生而把这个包删了,那么“test”包就会出现很多错误。那么怎么结决这个这一系列的问题呢?请看下面解决方法。

    关于新版ADT创建项目时出现appcompat_v7的问题
    END

解决方法

  1. 1

    首先解决项目建成后appcompat_v7包出错。test包出现红色警告的问题。

    点击菜单栏"Project",选择"Clean",然后点击"OK",Clean完成后,你会发现appcompat_v7包出错。test包出现红色警告的问题已经解决了,只是test包还有黄色警告,那只是因为test的Java文件中import的类没有被使用,所以完全不用管它。

    如果还不管用,那么右键appcompat_v7包,选择Properties,点"Android",如果Library栏下的"Is Library"方框没勾选,则勾选上,点击"OK",然后再照以上步骤执行"Clean"操作即可。

    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
  2. 2

    appcompat_v7包删除后,test项目各种出错,说明test项目是依赖于appcompat_v7包的,所以这个appcompat_v7包是不能被删除的。那么你不用管这个包,直接做你的项目就行了。

  3. 3

    如果你依旧对appcompat_v7包耿耿于怀,我告诉你一个建项目时不出现appcompat_v7包的方法。既然appcompat_v7包是一个能让2.1以上全使用上4.0版本的界面的支持库,那么如图所示,我们建项目时直接把最小SDK选在Android4.0以上不就不需要这个支持库了吗?结果证明我们的想法是对的。

    关于新版ADT创建项目时出现appcompat_v7的问题
    关于新版ADT创建项目时出现appcompat_v7的问题
    END

注意事项

  • 以上图例均在笔者电脑(win8.1,ADT22.6.0)上亲测所得,对于读者出现的其他有关问题,本经验仅供参考。


本文转载自:http://blog.csdn.net/caiwenfeng_for_23/article/details/41862365

蜀山下的鱼
粉丝 9
博文 405
码字总数 0
作品 0
广州
高级程序员
私信 提问
Android第五课 编译错误分析

1)Error 1C/C++ Problem 问题 DescriptionDescription Resource Path Location Type make.exe: *** [obj/local/armeabi-v7a/libtest.so] Error 1C/C++ Problem 解决 通过Eclipse无法定位到相......

fengyuzaitu
2018/08/07
0
0
Eclipse新建项目报错

使用Eclipse新建项目时,minSdkVersion="8",targetSdkVersion="19". 自动生成appcompat v7.但是依赖包报错,项目红色感叹号。更加不可理解的是提示 D:\DailyStudy\Android\NDKProject\appco......

wolfbigbig
2016/03/01
320
2
使用eclipse创建android工程时得到警告

警告信息如下: [2014-12-06 11:41:59 - appcompat_v7] WARNING: unable to write jarlist cache file /home/fuhd/work/workspace/android/appcompat_v7/bin/jarlist.cache 在创建Android项目......

柳哥
2014/12/06
1K
0
关于OSC Android v2版中osc-android-app-appcompat-v7的疑问

小弟试着把新版的往Android Studio里面丢。发现osc-android-app-appcompat-v7很难部署。老出现error: Duplicate file.的错误。这应该怎么搞呢?是否有经验的朋友指点下。 另外:新版的png的图...

听_风
2015/05/19
433
2
Android studio 使用心得(三)---从Eclipse迁移到Android studio

断断续续的也算是把eclipse上的代码成功迁移到android studio上来了,现在,我同事继续用eclipse,我用android studio,svn上还是之前eclipse的项目,迁移成功后,我也能happy的开发了,两不误...

veidy
2015/01/21
3.2K
10

没有更多内容

加载失败,请刷新页面

加载更多

精华帖

第一章 jQuery简介 jQuery是一个JavaScript库 jQuery具备简洁的语法和跨平台的兼容性 简化了JavaScript的操作。 在页面中引入jQuery jQuery是一个JavaScript脚本库,不需要特别的安装,只需要...

流川偑
15分钟前
3
0
语音对话英语翻译在线翻译成中文哪个方法好用

想要进行将中文翻译成英文,或者将英文翻译成中文的操作,其实有一个非常简单的工具就能够帮助完成将语音进行翻译转换的软件。 在应用市场或者百度手机助手等各大应用渠道里面就能够找到一款...

401恶户
27分钟前
2
0
jenkins 插件下载加速最终方案

推荐做法 1、告诉jenkins 我哪些插件需要更新 jenkins插件清华大学镜像地址 https://mirrors.tuna.tsinghua.edu.cn/jenkins/updates/update-center.json 1.进入jenkins系统管理 2.进入插件管...

vasks
33分钟前
3
0
composer爆错:zlib_decode():data error

解决办法:先用 composer diagnose 命令检测 然后 composer self-update 更新composer版本 最后执行 composer update 或者 composer install composer 切换阿里云镜像 用起来还快 composer c...

koothon
39分钟前
3
0
shangcheng-my

1.数据库主键、外键类型为bigint,那么在后台应该用什么类型的变量定义? 后台用string接收,因为前段传过来的一般都是json字符串,后台直接接收,mysql是可以吧数字类型的字符串转换为对应的...

榴莲黑芝麻糊
昨天
4
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部