源码编译安装tensorflow

原创
2018/12/07 09:33
阅读数 303

好久没有玩tensorflow,看到新闻1.12版本发布了,心血来潮找个服务器安装一下

首先

pip3 install -U tensorflow

安装顺利,然后启用python3

import tensorflow as tf 

提示不支持AVE,这是什么鬼?????

在服务器上执行命令,查看一下cpu

cat /proc/cpuinfo 

竟然不支持AVE指令集,好吧,公司比较单薄,用的都是古董,看一下tensorflow,1.6版本官方发布的whl包支持AVE了,如果cpu不支持AVE只能自己编译,看来需要打怪了。

准备工作

下载bazel,google的构建编译工具,虽然没用过,但是不复杂。

下载最新的tensorflow1.12

tar -zxvf tensorflow-1.12.0.tar.gz

cd tensorflow-1.12.0

./configure

 查看cpu支持sse4_1和sse4_2

bazel build -c opt --copt=-msse4.1 --copt=-msse4.2 //tensorflow/tools/pip_package:build_pip_package

然后就是漫长的等待,如果没有错误使用下面的命令生成pip包

 bazel-bin/tensorflow/tools/pip_package/build_pip_package /opt

pip3 install -U /opt/tensorflow.whl

 

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部