材料设计保持兼容

原创
2015/01/21 14:26
阅读数 9

原文地址:http://developer.android.com/training/material/compatibility.html

一些材料设计功能像是材料主题、自定义activity移动,只能在android5.0之后才能用,然而你也能低版本的android设备中兼容材料设计功能。

定义替代的样式

你可以你的应用在支持的设备上使用材料设计,在更早的设备上使用原来的主题

1、定义一个主题继承旧的主题,在res/values/styles.xml中

2、在res/values-v21/styles.xml中定义一个一样的主题继承与材料主题

3、设置这个主题为你应用的主题

如果你的应用使用了材料设计主题,但是没有提供一个替换的主题,该应用将无法在就版本的设备中运行

提供替代的布局。否则,就需要提供替换的布局。

如果你的布局是依照材料设计规则设计的,但没有使用android5.0新的属性,那么在旧版本中也是能运行的。

针对android5.0的布局文件放到res/layout-v21目录下,替换的布局文件放到res/layout下,

使用支持包

v7支持包支持一下材料设计功能:

1、针对一些系统组件的材料设计样式

2、颜色面板主题属性

3、RecyclerView组件

4、CardView组件

5、 Palette

Theme.AppCompat主题支持的材料设计样式组件:

EditText、Spinner、CheckBox、RadioButton、SwitchCompat、CheckedTextView

校验系统版本

以下功能只有在android5.0版本以上才能使用

1、activity移动

2、触摸反馈

3、显示动画

4、基于路劲动画

5、矢量图

6、图片着色

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部