CentOS 7安装Erlang/OTP 18.3

原创
2017/10/19 10:49
阅读数 2.9K

CentOS 7安装Erlang/OTP 18.3
官方推荐从源码安装Erlang,因此下面开始从源码安装OTP 18.3。

一、下载OTP 18.3源码:http://www.erlang.org/download/otp_src_18.3.tar.gz

  1. # tar zvxf otp_src_18.3.tar.gz  
  2. # mv otp_src_18.3/ otp  
  3. # cd otp  
  4. # ./configure --prefix=/usr/local/erlang --with-ssl -enable-threads -enable-smmp-support -enable-kernel-poll --enable-hipe --without-javac 

报错:
configure: error: No curses library functions found
configure: error: /bin/sh '/root/otp/erts/configure' failed for erts
解决:

  1. # yum -y install ncurses-devel  

 二、继续 # ./configure --prefix=/usr/local/erlang --with-ssl -enable-threads -enable-smmp-support -enable-kernel-poll --enable-hipe --without-javac

报错:
*********************************************************************
**********************  APPLICATIONS DISABLED  **********************
*********************************************************************
crypto         : No usable OpenSSL found
jinterface     : Java compiler disabled by user
odbc           : ODBC library - link check failed
orber          : No C++ compiler found
ssh            : No usable OpenSSL found
ssl            : No usable OpenSSL found
*********************************************************************

解决:

  1. # yum list | grep ssl  
  2. # yum install openssl-devel  

三、继续 # ./configure --prefix=/usr/local/erlang --with-ssl -enable-threads -enable-smmp-support -enable-kernel-poll --enable-hipe --without-javac

报错
*********************************************************************
**********************  APPLICATIONS DISABLED  **********************
*********************************************************************
jinterface     : Java compiler disabled by user
odbc           : ODBC library - link check failed
orber          : No C++ compiler found
*********************************************************************

解决:

  1. # yum list | grep ODBC  
  2. # yum install unixODBC-devel  

四、继续 # ./configure --prefix=/usr/local/erlang --with-ssl -enable-threads -enable-smmp-support -enable-kernel-poll --enable-hipe --without-javac
 

报错
*********************************************************************
**********************  APPLICATIONS DISABLED  **********************
*********************************************************************
jinterface     : Java compiler disabled by user
orber          : No C++ compiler found
*********************************************************************

解决:

  1. # yum install gcc-c++   

五、继续 # ./configure --prefix=/usr/local/erlang --with-ssl -enable-threads -enable-smmp-support -enable-kernel-poll --enable-hipe --without-javac

OK!!!没报错了,下面就执行: 

  1. # make  
  2. # make install 

漫长的等待... 安装完成!

六、测试Erlang是否安装正确

[root@localhost bin]# /work/install/erlang/bin/erl
Erlang/OTP 18 [erts-7.3] [source] [64-bit] [smp:4:4] [async-threads:10] [hipe] [kernel-poll:false]

Eshell V7.3  (abort with ^G)
1> 

 安装成功啦!!!


七、在PATH环境变量添加Erlang的bin路径,以便执行。

# erlang env conf
ERLANG_HOME=/work/install/erlang
PATH=$PATH:$ERLANG_HOME/bin

【安装总结】

从源码编译安装Erlang,有两个库或工具是必须的:

一是完整的GCC编译器环境
二是Ncurses开发库
 

还有一些库或工具,如果没有它们,在编译配置时会出现警告信息,而且可能不能通过配置。这些库有:

1)OpenSSL开发库

2)ODBC开发库

3)Java编译器

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部