UOS qt5 misp

原创
2020/07/17 16:38
阅读数 627

sudo apt install build-essential

sudo apt install qt5-default

sudo apt install gcc-multilib dpkg -l openssl*

##install depend 需要xcb的支持

sudo apt-get install '^libxcb.*-dev' libx11-xcb-dev libglu1-mesa-dev libxrender-dev libxi-dev libxkbcommon-dev libxkbcommon-x11-dev
sudo apt-get install libssl-dev libxcursor-dev libxcomposite-dev libxdamage-dev libxrandr-dev libdbus-1-dev libfontconfig1-dev libcap-dev libxtst-dev libpulse-dev libudev-dev libpci-dev libnss3-dev libasound2-dev libxss-dev libegl1-mesa-dev gperf bison

shadow build

mkdir qt5-build
cd qt5-build
../qt-everywhere-src-5.12.9/configure -release -opensource -nomake examples -nomake tests -skip webengine   -confirm-license

展开阅读全文
加载中

作者的其它热门文章

打赏
0
0 收藏
分享
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部