compass 使用过程遇到的问题(linux 系统下)

原创
2015/09/13 21:33
阅读数 321

compass 主要是用来编译sass

sass 是基于 ruby的 所以如果还没安装ruby 需要安装ruby

// 安装ruby前  换掉源
$ gem sources --remove https://rubygems.org/
$ gem sources -a https://ruby.taobao.org/
$ gem sources –l

//要使用dev 版本不然安装compass的时候会出错
//ERROR: Failed to build gem native extension.

sudo apt-get install ruby2.1-dev build-essential    

安装完ruby 然后执行 以下命令 安装compass 会连同安装sass

sudo gem install compass    
展开阅读全文
打赏
0
1 收藏
分享
加载中
更多评论
打赏
0 评论
1 收藏
0
分享
返回顶部
顶部