文档章节

交换路由大作业

丌官尚雄
 丌官尚雄
发布于 2019/12/08 17:54
字数 811
阅读 120
收藏 0

交换路由大作业


1. 选取设备

设备 接口 IP地址 子网掩码
Vlan80 虚拟接口 10.10.3.129 255.255.255.128
Vlan30 虚拟接口 10.10.2.1 255.255.255.0
Vlan20 虚拟接口 10.10.0.1 255.255.254.0
Vlan10 虚拟接口 10.10.3.1 255.255.255.128
R1 F0/0 1.1.1.2 255.255.255.0
S0/0 2.2.2.1 255.255.255.0
R2 S0/0 2.2.2.2 255.255.255.0
Loopback 0 3.3.3.3 255.255.255.0
ESW1 F0/0 1.1.1.1 255.255.255.0

根据题目给定的信息,选取如下节点设备

  • 一台三层交换机(3650-24ps)
  • 两台核心路由器(2811)
  • 两台二层交换机(2960-24TT)
  • 四台电脑 --> 用来测试Vlan,及其连通性
  • 三台服务器(DNS,WWW, Internet)

2. 规划网络

2.1. 规划Vlan

一号楼

根据给定的信息现将Vlan规划如下 一号楼二层交换机命令如下:

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name 20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#name 30
Switch(config-vlan)#exit
Switch(config)#vlan 80
Switch(config-vlan)#name 80
Switch(config-vlan)#exit
Switch(config)#

二号楼 二号楼二层交换机命令(略)

2.2. Vlan绑定端口

2.2.1. 一号楼二层交换机命令如下:

Switch(config)#interface FastEthernet0/2
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#interface FastEthernet0/3
Switch(config-if)#switchport access vlan 20
Switch(config-if)#exit
Switch(config)#interface FastEthernet0/4
Switch(config-if)#switchport access vlan 30
Switch(config-if)#exit
Switch(config)#interface FastEthernet0/5
Switch(config-if)#switchport access vlan 80
Switch(config-if)#exit

2.2.2. 二号楼交换机命令(略)

2.2.3. 接通终端设备配置IP etc.(略)

Vlan10中的终端IP配置如下:

Packet Tracer PC Command Line 1.0
C:\>ipconfig

FastEthernet0 Connection:(default port)

   Link-local IPv6 Address.........: FE80::2E0:B0FF:FE85:E047
   IP Address......................: 10.10.3.10
   Subnet Mask.....................: 255.255.255.128
   Default Gateway.................: 10.10.3.1

C:\>

其他配置略

trunk Vlan间通信

配置二层交换机的F0/0为trunk,命令如下:

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface FastEthernet0/1
Switch(config-if)#
Switch(config-if)#switchport mode trunk

Vlan内跨交换机通信,ping命令执行如下:

Vlan间通信,ping命令执行如下:

规划路由

路由器R1,配置如下:

Router>enable
Router#config 
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 1.1.1.2 255.0.0.0
Router(config-if)#ip address 1.1.1.2 255.255.255.0
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#ip address 2.2.2.1 255.0.0.0
Router(config-if)#ip address 2.2.2.1 255.255.255.0
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.1
Router(config)#ip route 0.0.0.0 0.0.0.0 2.2.2.2
Router(config)#ip nat pool test 2.2.2.3 2.2.2.10 netmask 255.255.255.0
Router(config)#int se 0/0/0
Router(config-if)#ip nat outside
Router(config-if)#ipiexit
Router(config)#int f0/0
Router(config-if)#ip nat inside
Router(config-if)#end

路由器R2配置命令如下:

Router>enable
Router#config 
Configuring from terminal, memory, or network [terminal]? 
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 1.1.1.2 255.0.0.0
Router(config-if)#ip address 1.1.1.2 255.255.255.0
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#ip address 2.2.2.1 255.0.0.0
Router(config-if)#ip address 2.2.2.1 255.255.255.0
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.1
Router(config)#ip route 0.0.0.0 0.0.0.0 2.2.2.2
Router(config)#ip nat pool test 2.2.2.3 2.2.2.10 netmask 255.255.255.0
Router(config)#int se 0/0/0
Router(config-if)#ip nat outside
Router(config-if)#ipiexit
Router(config)#int f0/0
Router(config-if)#ip nat inside
Router(config-if)#end

最终拓扑图

© 著作权归作者所有

丌官尚雄

丌官尚雄

粉丝 1
博文 42
码字总数 42803
作品 0
烟台
后端工程师
私信 提问
加载中

评论(0)

企业网、数据通信网,企业培训,欢迎各位金主

乾颐堂大路由企业培训乾颐堂大路由项目组在周亚军老师带领下已经培养出700+的互联网专家,同时也可以为广大企事业单位提供思科、华为网络设备和基础架构培训,使得您的员工可以快速操控和维护...

EnderJoe
2018/01/02
0
0
linux学习作业-第八周

本周作业内容: 1、请描述网桥、集线器、二层交换机、三层交换机、路由器的功能、使用场景与区别。 网桥是早期的两端口二层网络设备,用来连接不同网段。网桥的两个端口分别有一条独立的交换...

rExcHow
2016/10/15
0
0
大型局域网中二层结构与三层结构

大型局域网中二层结构与三层结构 大型局域网结构千变万化。网络的规划与园区环境、应用类型密不可分。就目前而言网络结构分为大二层与三层结构。未来的发展方向是向sdn靠拢,我个人观点是自动...

gaofengqiang
2014/11/26
0
0
「 ThoughtWorks面试 —— 一次愉快的技术交流 | 掘金技术征文」

前言   作为一名前端程序猿,ThoughtWorks的面试在一定程度上冲击了我的认知,面试过程中不仅让我了解了自身优势,也对自己不足有了很深的认知,抛开面试结果来说,整个面试过程就是一次愉...

yacnlee
2018/07/05
0
0
学习韩立刚老师IT运维课程,成为韩立刚老师正式学生,在全国范围为你就近推荐工作。

2018年5月21日,万恒教育成立IT运维就业指导部门,为韩立刚老师正式学生推荐工作,实习单位。和国内IT外包公司HR长期合作,韩立刚老师技术考核通过的学生,为学生在全国范围就近推荐工作。 ...

onesthan
2018/05/22
0
0

没有更多内容

加载失败,请刷新页面

加载更多

docker容器内apt快速更换国内源

mv /etc/apt/sources.list /etc/apt/sources.list.bakecho "deb http://mirrors.163.com/debian/ jessie main non-free contrib" >> /etc/apt/sources.listecho "deb http://mirrors......

Rhynie
28分钟前
15
0
Handlers与Controls

本教程假设您已经阅读了Leaflet Class Theory 在leaflet中, 一个layer是跟随map移动的任何东西。 与之相反,一个control是对于map容器相对静态的HTML元素(例如,缩放、全屏的按钮都是contr...

东东笔记
28分钟前
19
0
kafka压测之producer

背景 前不久自建了大数据平台,由于时间问题,排期紧张,未能对平台进行压测。现在平台搭建完成,计划对平台组件逐一进行一次压测。 欢迎指正,不喜勿喷! 压测目标 测试Kafka集群写入消息和...

阿dai学长
31分钟前
9
0
DRF: drf_yasg swagger 文档http -> https

drf_yasg 文档https配置 参考 django 配置 settings.py USE_X_FORWARDED_HOST = TrueSECURE_PROXY_SSL_HEADER = ('HTTP_X_FORWARDED_PROTO', 'https') nginx 配置 加入X-Forwarded-Proto在......

hyhlinux
40分钟前
19
0
Docker存储驱动之--overlay2

docker支持多种graphDriver,包括vfs、devicemapper、overlay、overlay2、aufs等等,其中最常用的就是aufs了,但随着linux内核3.18把overlay纳入其中,overlay的地位变得更重,最近也在自己的...

Jack088
40分钟前
9
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部