CentOS6.3 安装IBM WebSphere

原创
2013/05/21 14:26
阅读数 3.3K

在CentOSX86_64上安装WAS7真不容易,搞了大半天才成功,呃、、、果断记下来

1、下载

最新版是8.5,可以下载到was.repo.8500.developers.ilan_part1~3.zip,3G多吧,但是,下完不会装(汗)

我装的7的试用版。下载地址反正就是官网找找的,下载完was.cd.70011.trial.base.opt.linux.ia32.tar.gz

2、安装

以root用户即可。

tar -zxvf was.cd.70011.trial.base.opt.linux.ia32.tar.gz

./launchpad.sh

3、纠结的错误:找不到支持的浏览器,明明装的有火狐。后来发现是火狐版本太高,10.0.12,需要改一下

vim launchpad/browser.sh

找到

supportedFirefoxVersion一段,发现里面只定义了1-9版本的firefox,在return 1之前加一句

*Firefox\ 1[0-9].*) return 0;;

4、再次启动,顺利打开网页,但是点击启动安装程序按钮,没反应,也不报错误。这才是蛋疼的地方

5、怎么解决?原因是was在64位的Linux上安装,需要安装32位的兼容包,以下包必须安装32位和64位的包:

  • compat-libstdc++-33-3.2.3-69
  • compat-db-4.6.21-15
  • libstdc++-4.4.4-13
  • libXp-1.0.0-15.1
  • libXmu-1.0.5-1
  • libXtst-1.0.99.2-3
  • pam-1.1.1-4
  • libXft-2.1.13-4.1
  • gtk2-2.18.9-4
  • gtk2-engines-2.18.4-5
例如:yum install pam.i686 pam.x86_64

还需要安装的包(只需要安装X86_64版本的即可)

  • ksh-20100621-2
  • elfutils-0.148-1
  • elfutils-libs-0.148-1

大概就这些了,本人网络环境比较复杂,yum 都是代理上网,网速很慢,所以记不得许多;直接下载安装的话,依赖项好多,难整。

另外,32位包与64位包同时安装时,需要保证两个版本号一致,如果之前已经安装某个32位的包1.1,后面又要安装一个64位的包,但是现在这个64位包的版本是1.2了,这样安装就会失败,应该先升级1.1的,直接yum install XXX即可自动升级,然后再装即可。

6、完了,启动顺利进入图形界面,乱码。。。

unset LANG

再来,纯英文,真爽。

7、后面傻瓜化操作,一步一步来,就没什么需要注意的了,怎么玩都行!

8、默认安装目录/opt/IBM/App*记不得了。启动、关闭:**/bin/startServer.sh server1 

stopServer server1 即可

默认控制台:localhost:9060

9、打完收工

10、后记

后来发现直接有WAS 64位for develpoers的版本,很轻松就安装成功了!!!汗,勿效仿贫道噢

展开阅读全文
打赏
1
4 收藏
分享
加载中
was.repo.8500.developers.ilan_part1~3.zip
这个要怎么下载啊,找了好久没有找到
2015/12/11 10:11
回复
举报
更多评论
打赏
1 评论
4 收藏
1
分享
返回顶部
顶部