前端模块管理构建node&npm&duo

原创
2016/08/11 18:06
阅读数 11

1.安装node-0.12.15 此版本不支持cnpm 下载最新版(gcc4.4.7可以编译的),gcc4.4.7以上的版本可以按照node4.X

wget https://nodejs.org/dist/latest-v0.12.x/node-v0.12.15.tar.gz
tar xvf node-v0.12.15.tar.gz
cd node-v0.12.15
make && make install

2.安装npm最新版(3.10.5)

curl -L https://www.npmjs.com/install.sh | sh
#默认镜像站 https://registry.npmjs.org/,更换为国内淘宝镜像
#npm config set registry https://registry.npm.taobao.org 
#npm config get registry	#查看镜像

3.安装duo.js包管理工具

npm install -g duo

其它构建工具:

Bower Grunt Composer Gulp fis3 Browserify Webpack spm component

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部