文档章节

Cassandra : Unsupported major.minor version 52.0解决

skyPZ555
 skyPZ555
发布于 2016/03/30 17:45
字数 206
阅读 213
收藏 0
  1. 今天安装了apache-cassandra-3.4-bin.tar.gz,下载:http://cassandra.apache.org/download/

  2. 版本:apache-cassandra-3.4-bin.tar.gz 

  3. OS :Win10 

    java 和Python 版本如下

    java -version

    java version "1.8.0_77"

    Java(TM) SE Runtime Environment (build 1.8.0_77-b03)

    Java HotSpot(TM) 64-Bit Server VM (build 25.77-b03, mixed mode

    python --version : Python 2.7.11

  4. 下载后解压,启动cassandra.bat报出org/apache/cassandra/service/CassandraDaemon : Unsupported major.minor version 52.0错误。Google了一下,http://stackoverflow.com/ 说是jdk 太低的原因,将jdk从1.7 升级到1.8,仍旧报出以上错误。

  5. 之后折腾了许久,终于发现是设置的问题,要在E:\apache-cassandra-3.4\bin\cassandra.bat进行设置,

  6. cassandra.bat和cassandra.in.bat中添加以下语句

    set JAVA_HOME=D:\Program Files\Java\jdk1.8.0_77

    set CASSANDRA_HOME=E:\apache-cassandra-3.4

  7. 再次启动cassandra.bat,正常启动.

  8. 其他

      CQL 文档:http://docs.datastax.com/en/cql/3.3/pdf/cql33.pdf

                       http://docs.datastax.com/en/landing_page/doc/landing_page/current.html



© 著作权归作者所有

skyPZ555
粉丝 1
博文 2
码字总数 217
作品 0
武汉
私信 提问
项目在Intellij idea 2.5能运行,但Intellij idea 3不能运行

原来在Intellij idea 2.5里能正常运行的项目,到Intellij idea 3 公开预览版这个版本里怎么就不能正常运行了呢?报jdk版本过低的错,这是怎么回事? Error:Internal error: (java.lang.Unsup...

K哥
2016/10/27
312
2
Unsupported major.minor version

这种错误先效验一下自己的版本是否对应,如果版本对应正确就是JDK版本过低需升级对应版本; 48,49,50, 51 , 52是Java编译器内部的版本号: Unsupported major.minor version 52.0 对应于 JD...

cheves
2016/05/06
80
0
Android Studio:Failed to load the LayoutLib

最近在做demo,升级了一下SDK 7.0,发现预览布局文件的时候,发现提示错误 Failed to load the LayoutLib: com/android/layoutlib/bridge/Bridge : Unsupported major.minor version 52.0 查...

u010635353
2016/10/09
0
0
项目中引用了Word提示JDK 版本对不上怎么办?我是JDK1.7的

@杨尚川 你好,想跟你请教个问题: 我的项目中引用了word1.3.jar pinyin4j等 项目报错: java.lang.UnsupportedClassVersionError: org/apdplat/word/analysis/TextSimilarity Unsupported m......

杨Gang
2016/11/25
227
1
Xamarin中Unsupported major.minor version 52.0问题解决

Xamarin中Unsupported major.minor version 52.0问题解决 出现这种问题,是由于所使用的Java代码使用Java 8所才具有的特性。这个时候,需要将JDK升级到JDK 8的32位。其中,52是Java SE 8的内...

大学霸
2016/06/17
174
0

没有更多内容

加载失败,请刷新页面

加载更多

OSChina 周日乱弹 —— 别问,问就是没空

Osc乱弹歌单(2019)请戳(这里) 【今日歌曲】 @tom_tdhzz :#今日歌曲推荐# 分享容祖儿/彭羚的单曲《心淡》: 《心淡》- 容祖儿/彭羚 手机党少年们想听歌,请使劲儿戳(这里) @wqp0010 :周...

小小编辑
今天
163
4
golang微服务框架go-micro 入门笔记2.1 micro工具之micro api

micro api micro 功能非常强大,本文将详细阐述micro api 命令行的功能 重要的事情说3次 本文全部代码https://idea.techidea8.com/open/idea.shtml?id=6 本文全部代码https://idea.techidea8....

非正式解决方案
今天
5
0
Spring Context 你真的懂了吗

今天介绍一下大家常见的一个单词 context 应该怎么去理解,正确的理解它有助于我们学习 spring 以及计算机系统中的其他知识。 1. context 是什么 我们经常在编程中见到 context 这个单词,当...

Java知其所以然
昨天
5
0
Spring Boot + Mybatis-Plus 集成与使用(二)

前言: 本章节介绍MyBatis-Puls的CRUD使用。在开始之前,先简单讲解下上章节关于Spring Boot是如何自动配置MyBatis-Plus。 一、自动配置 当Spring Boot应用从主方法main()启动后,首先加载S...

伴学编程
昨天
8
0
用最通俗的方法讲spring [一] ──── AOP

@[TOC](用最通俗的方法讲spring [一] ──── AOP) 写这个系列的目的(可以跳过不看) 自己写这个系列的目的,是因为自己是个比较笨的人,我曾一度怀疑自己的智商不适合干编程这个行业.因为在我...

小贼贼子
昨天
8
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部