文档章节

Deepin安装Eclipse

划破的天空
 划破的天空
发布于 2018/04/05 20:49
字数 435
阅读 442
收藏 0

Deepin安装Eclipse

系统环境:Deepin 15.5
软件环境:Eclipse 4.7

官网下载最新版elipse(4.7)安装板或压缩版均启动失败(弹框报错),原因是deepin默认安装的openjdk1.9的版本,而eclipse支持的最低版本为jdk1.8版本,本机又需要jdk1.7版本的,因此需要修改eclipse启动vm参数才可以正常运行.

Configure Eclipse for Java9

方案一

1 启动时添加vm参数,当次启动有效

./eclipse -vm /jdk_path/bin/java

2 修改eclipse.init文件,增加vm参数来指定启动1.8版本

-startup
plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.551.v20171108-1834
-product
org.eclipse.epp.package.jee.product
-showsplash
org.eclipse.epp.package.common
--launcher.defaultAction
openFile
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vm
/home/jason/local/jdk1.8.0_144/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.8
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
--add-modules=ALL-SYSTEM
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m

方案二

通过将默认JDK设为1.8,让eclipse能够正常启动,如需需要将自定义的jdk版本加入存储库中,使用下述命令

sudo update-alternatives --install /usr/bin/java java /usr/java/jdk1.8.0_144/bin/java 300
 
sudo update-alternatives --install /usr/bin/javac javac /usr/java/jdk1.8.0_144/bin/javac 300

列出当前存储库中已安装的JDK版本,已包含上述命令安装的jdk版本

sudo update-alternatives --display java

默认JDK版本

执行update-alternatives命令指定openJDK1.8版本,至于项目使用JDK通过eclipse指定即可

sudo update-alternatives --config java

设置JDK默认版本

查看当前系统默认jdk版本

$ java -version

java version "1.8.0_144"
Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
Java HotSpot(TM) 64-Bit Server VM (build 25.144-b01, mixed mode)

https://www.fank243.com/posts/75e08ba5.html

© 著作权归作者所有

共有 人打赏支持
下一篇: Linux 常用命令
划破的天空
粉丝 3
博文 25
码字总数 11842
作品 0
深圳
程序员
私信 提问
深度Linux使用小记 (附带视频)

深度Linux使用小记 Deepin Linux是由武汉深度科技有限公司开发的Linux发行版。Deepin 是一个基于 Linux 的操作系统,专注于使用者对日常办公、学习、生活和娱乐的操作体验的极致,适合笔记本...

OSSIM
2015/05/15
0
17
深度安装器--Deepin Installer

深度安装器是深度科技打造的一款简单易用、可定制化的安装程序。主要功能包含语言选择、帐户设置、时区选择、分区设置、安装进度与新功能介绍、安装反馈。 预览 项目地址 测试版地址: http...

匿名
2017/10/12
165
0
Deepin深度Linux系统安装记录

测试设备:小米游戏本,最新版15.6进入安装后发现黑屏,所以使用15.5安装 Deepin 15.5 官方介绍页 官方下载 百度云下载 下载后得到文件夹 将里面的ISO镜像文件,使用2345之类的虚拟光驱挂载 ...

兄弟要花吗
2018/08/02
0
0
Ubuntu 下安装深度音乐播放器

网上搜了一个安装深度音乐的有问题。 我自己又整理一个最新的2014版的深度音乐。 Linux环境:Ubuntu14.04 LTS 64bit 深度音乐都是DEB包安装。 下面,介绍如何安装深度音乐播放器。 需要pytho...

Nori
2014/11/19
0
0
deepin 2014.2 RC发布 —— 快速·稳定·易用

友情提示 1.由于deepin 2014.2 RC以Compiz作为窗口管理器(Compiz在虚拟机中表现不佳),因此请直接使用实体机安装,这样才能体验到deepin系统的华丽效果。 在未来的deepin 2015版本,我们将...

cxbii
2014/12/19
3.7K
29

没有更多内容

加载失败,请刷新页面

加载更多

Python+Appium自动化测试环境搭建

1.Android SDK 下载SDK并配置系统环境变量ANDROID_HOME。 2.Appium 2.1 直接下载安装 官网下载安装appium-desktop-setup.exe。 2.2 通过npm下载安装 appium本质是一个nodejs库所以要先安装n...

维他ViTa
37分钟前
2
0
【git命令】git远程操作相关命令(remote 、push、fetch 、pull)

git系统图 git remote 为了便于管理,Git要求每个远程主机都必须指定一个主机名。为了便于管理,Git要求每个远程主机都必须指定一个主机名。 git remote【查看创库名】 git remote 在我们c...

echojson
47分钟前
2
0
MacOS安装单机版HBase

MacOS安装HBase,必然是用于测试了,从简入手、从简配置。 直接通过brew安装即可: brew install hbase 成功安装后,验证是否成功,如果不出意外的话,应该有如下输出: RippleMBP:~ userna...

RippleChan
今天
3
0
linux下oracle随操作系统启动而启动

大家一定还记得,我们在windows下安装oracle后,重起windows,数据库会自动启动,但在linux下,如果我们重起了操作系统, 就会发现数据库需要手工去输入,这个本来有好处,让dba知道操作系统已经重起...

突突突酱
今天
4
0
nacos之springboot

本地操作系统:ubuntu18,我使用docker的方式启动nacos服务 docker image方式启动nacos 在docker hub上可以搜到nacos-server List-1.1 拉去最新的版本 mjduan@mjduan-ubuntu:/opt/software$ ...

克虏伯
今天
3
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部