文档章节

CISCO交换机,路由器配置全集

SANSOM
 SANSOM
发布于 2013/08/04 23:05
字数 3160
阅读 37
收藏 0

交换机命令

Switch#config t

Switch(config)#enable secret cisco          设置进入特权模式的密码

Switch(config)#hostname                  交换机命名

Switch(config)#interface Ethernet0/1        进入接口模式

Switch(config)#interface vlan 1             进入vlan接口模式

Switch(config-if)#ip address 192.168.10.1 255.255.255.0 添加地址

Switch(config)#ip default-gateway 192.168.1.1    添加默认网关

 

Switch(config)#line vty 0 4

Switch(config-line)#password cisco             配置telnet的密码

Switch(config-line)#login

 

Switch(config-ethernet0/1)#duplex [half/full/auto]  配置端口双工工作状态

Switch(config-ethernet0/1)#speed [auto/100/10]    配置端口工作速度 

Switch(config-ethernet0/1)#no shutdown         关闭/启动端口

Switch(config-ethernet0/1)#exit                 推出系统

 

1.switch# erase startup-config            删除以前配置过的vlan

2.switch#delete vlan.dat                 都要删除在重启

3Reboot                             从启动

Switch#vlan database                         创建vlan

Switch#config t  

Switch(config)#vlan 3

Switch(config-vlan)#name vlan 3               命名vlan

Switch(config-ethernet0/1)#switchport mode access   允许该端口为通过模式

Switch(config-ethernet0/1)#switchport access vlan 3   vlan3加如到此端口

或(主干道设置)

Switch(config-ethernet0/1)#switchport mode trunk    设置此端口为trunk模式

Switch(config-ethernet0/1)#switchport trunk allowed vlan all  允许所有的vlan通过

Switch(config-ethernet0/1)#exit

Switch#show vlan {vlan_id}                         查看vlan

 

Vlan中配置stp(生成树协议)

Switch(config)#spanning-tree vlan 200 ------生成树在vlan 200中启用

Switch(config)#spanning-tree vlan 200 priority 4096--生成树中的vlan 200端口设置优先级

Switch(config-if)#spanning-tree cost 18-----生成树中的所有接口的花费值都设为18

Switch(config-if)#spanning-tree vlan 200 cost 17在生成树vlan 200中的接口的花费值设为17

Switch#show spanning-tree vlan vlan-id detail---查看某个vlan中生成树的详细信息

POrt fast的配置

 intface f0/24  ------------------一般连接的是服务器的端口

 spanning-tree partfast  (转发数据快无需等待30妙直接转发)

 spanning-tree partfast bpduguard (如果在此接口上接到bpdu报文此端口会马上shutdown)

  配置VTP服务器进行vlan的复制

   Switch  config

   Switch # vtp server----------------启动vtp服务器

   Switch # vtp domain domain-name----------设置域

   Switch # vtp password password ----------设置密码

   Switch # vtp pruning -------------------------启用裁剪 (优化配置)

   # show vtp      ----------------------查看配置

配置客户端

   Switch # config t

   Switch # vtp mode client

  Switch # vtp domain domain-name

   Switch # vtp password

例:

  交换机vlan 配置

 创建vlan

  Ra(config)# vlan 11 ----普通vlan

  Ra(config)# vlan 12-----普通vlan

  Ra(config)# vlan 13-----普通vlan

  Ra(config)# vlan 100-----管理vlan

 将交换机的端口加入到具体的vlan

  Ra(config)# interface f0/1

  Ra(config)# switchport mode access

  Ra(config)# switchprot access vlan 11

 

  Ra(config)# interface f0/2

  Ra(config)# switchport mode access

  Ra(config)# switchprot access vlan 12

 

  Ra(config)# interface f0/3

  Ra(config)# switchport mode access

  Ra(config)# switchprot access vlan 13

 配置管理vlan

  Ra(config)# ip default-gateway 192.168.100.1 ---交换机的默认网关

  Ra(config)# interface vlan 100----------给管理vlan添加具体的地址

  Ra(config)# ip add 192.168.100.2 255.255.255.0

 配置主干道(交换机和路由连接都要用到主干道)

  Ra(config)# interface f0/24

  Ra(config)# switchport mode trunk

  Ra(config)# switchport trunk allowed vlan all

 配置三层交换机

  Ra(config)# interface fa1/0/24

  Ra(config)# switchport trunk encapsulation dot1Q

  Ra(config)# switchport mode trunk

  Ra(config)# switchport trunk allowed vlan all

 创建虚拟vlan并加入地址(是前面vlan的默认网关)

  Ra(config)# vlan 11

  Ra(config)# ip add 192.168.11.1 255.255.255.0

  Ra(config)# vlan 12

  Ra(config)# ip add 192.168.12.1 255.255.255.0

  Ra(config)# vlan 13

  Ra(config)# ip add 192.168.13.1 255.255.255.0

  Ra(config)# vlan 100

  Ra(config)# ip add 192.168.100.1 255.255.255.0

 路由器配置命令

Router#show version           显示系统硬件信息及寄存值

Router#show run                      显示配置信息

Router#show users                        查看当前连接道路由器的用户

Router#show interfaces[ ID ] 查看接口的配置

Router#show running-config  查看内存RAM中的信息

Router#show startup-config         查看NVRAM中的信息

Router#show flash                 查看FLASH    中的信息

Router#cp running-config startup-config    RAM中的信息拷贝道RVRAM

Router#erase startup-config                删除NVRAM中的信息

Router(config- seria0)#encapsulation ppp用协议来对串口进行封装

Router#reload                  重启动路由器

Router#show controllers serial0   查看serical0这个接口是DCE还是DTE

Router(config- seria0)#clock rate 1000   如果此端口是DCE设置时钟平率

Router#show cdp neighbors detail      查看相邻的邻居路由信息

Router#clear ip route *            清空路由表

Router#show ip route         查看路由表

Router(config)#hostname R1       更改主机名

Router(config)#enables secret cisco    设置口令

Router(config)#service password-encryption  启用密码加密系统                               

 

Router(config)interface serial0        进入接口

Router(config-serial0)#ip add 192.168.0.1 255.255.255.0

Router(config-serial0)#no shutdown       激活接口

 

静态路由

Router(config)ip route 0.0.0.0 0.0.0.0 192.168.1.2

 

动态路由:

配置RIP动态协议

 Router(config)#router rip ---------------启动rip

 Router(config-router)#network 10.8.0.0 255.255.0.0 ---宣告网段

 Router(config-router)#passive-interface ether 0  ----在这个接口不发送rip报文

 Router(config-router)#ip ripreceive version 1   ----只接受版本rip版本1

 Router(config-router)#ip split-horizon----------启用水平分割

 

配置rip版本2

 Router(config)#router rip  ------------启动rip

 Router(config-router)version 2 ----------使用rip的版本2

 Router(config-router)no auto-sunmmary -------不让自动汇总

 Router(config-router)network 10.8.0.0 255.255.0.0  --宣告网段

OSPF多区域配置

 Ra(config)#router ospf 1          ---------------------------------- 启动ospf

 Ra(config-router)#network 192.168.0.0 0.0.0.255 area 0 -------宣告网段

 Ra(config-router)#redistributed stutic subnets

 Ra(config)#ip route 172.16.1.0 255.255.255.0 loopback 0

 

 RB(config)#router osp 1

 RB(config-router)#network 192.168.0.0 0.0.0.255 area 0

 RB(config-router)#network 192.168.1.0 0.0.0.255 area 1

 RB(config-router)#area 1 stub no-summary

 

 Rc(config)#router osp 1

 Rc(config-router)#network 192.168.1.0 0.0.0.255 area 1

 Rc(config-router)#area 1 stub

注意:如果有其他区域或自治系统传入的路由要想让它变为默认路由则要用

    Nssa no-summary 不能和stub区一起用要先去掉stub

 

DHCP服务器的配置

   Router(config)#service dhcp   ------启动dhcp服务

   Router(config-dhcp)#ip dhcp pool name (服务器名)

   Router(config-dhcp)#network (跟网段)

   Router(config-dhcp)#dns-service (dnsip地址)

   Router(config-dhcp)#default-router (跟默认网关ip地址)

   Router(config-dhcp)#ip dhcp excluded-address (排除的地址)

Router(config)#ip helper-address 192.168.21.7   设置DHCP中继代理

 

访问控制列表

-、标准访问控制列表

  1router(config)#access-list <0-99> permit/deny 主机网段 反掩码 另一网段 反掩码

  例如: router(config)#access-list 1 deny icmp any any ------拒绝任何网段的icmp报文通过

二、扩展访问控制列表:

  1router(config)#access-list <100-199> permit/deny protocal

主机网段 反掩码 另一网段 反掩码 eq 端口号

  例如:

Router(config)#access-list 101 permit tcp 192.168.0.0 0.0.0.255 192.168.1.1 0.0.0.255 eq 23

router(config)#interface e0

router(config-route)#ip 192.168.1.1 255.255.255.0

router(config-route)#no shutdown

router(config-route)#ip access-group 101 in ----------------将此访问列表应用到e0这个接口上

             允许192.168.0.0这个网段的主机telnet192.168.1.1的路由器上 

 2router(config)#access-list 101 permit tcp 192.168.0.0 0.0.0.255 192.168.1.1 0.0.0.255 eq 23 log

                  如果后面加log则表示如果有条目匹配则5分钟生成一次日子消息

 ip access-list log-update threshold 1  ----此条表示如果有一条匹配就会生成一次日志

                          如果是2的话就表示有两条条目匹配就会生成一次日志             

三、基于时间的访问控制列表

      要求:

           允许在上班时间的早上8点到下午17点之间可以访问外网的www服务

           其他都拒绝

 1router(config)#access-list 101 permit tcp 192.168.0.0 0.0.0.255 any eq 80 time-range cisco (时间控制表名)

 2router(config)#time-range cisco  ---------------命名时间控制列表

    router(config)#Periodic weekdays 8:00 to 17:00    (周一到周五8点到17)

 3router(config)#interface e0          -----------应用于此端口

    router(config)#ip access-group 101 in   

四、命名访问控制列表

     扩展访问

 1、创建控制列表名为cisco 允许任何网段的网络来访问192.168.0.0这个网段的www服务其他的都决绝

   router(config)#ip access-list extended cisco

   Router(config-ext-nacl)#permit tcp any 192.168.0.0 0.0.0.255 eq 80

   router(config-ext-nacl)#deny ip any any

 2、将其应用到端口

   router(config)#interface e0

   router(config-route)#ip access-group cisco in

五、动态访问控制列表

   要求:只允许192.168.1.0网段的主机来访问192.168.1.1www服务并且只允许192.168.1.2 telnet192.168.1.1

 主机上如果被验证者为192.168.1.2打开所有的端口120分钟后自动断开连接

 1、创建一个叫cisco的动态访问控制列表

    router(config)# Access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 192.168.1.1 eq 80

    router(config)# Access-list 101 permit tcp host 192.168.1.2 host 192.168.1.1 eq 23

    router(config)# Access-list 101 dynamic cisco timeout 120 permit ip any any

 2、设立vty的密码并应用到vty

    router(config)#lint vty 0 4

    router(config-line)#password cisco

    router(config-line)#login

    router(config-line)#autocommand access-enable host timeout 10----如果telent被验证则自动会生成一张访问控制列表

 3、应用到f0端口上

    router(config)#interfave f0

    router(config-route)#ip access-group 101 in

六、 established实施访问控制列表

    192.168.1.0这个网段的主机可以访问任何外网的www服务但是来自任何外网的消息都要经过验证才可以进来

    router(config)#access-list 101 permit tcp 192.168.1.0 0.0.0.255 any eq 80

    router(config)#access-list 101 permit tcp any 192.168.1.0 0.0.0.255 established

     应用到端口

    router(config)#interface f0

router(config-route)#ip access-list 101 in

 

 

NAT------网络地址翻译 -----   主要解决网络地址部够用                     

NAT 静态的映射实例

应用于端口

 Router(config)#interface Ethernet0

 Router(config-router)#ip address 172.168.1.1 255.255.255.0

 Router(config-router)#ip nat inside(指定为内部接口)

 

 Router(config)#interface serial0

 Router(config-router)#ip address 200.1.1.1 255.255.255.0

 Router(config-router)#ip nat outside (指定外部接口)

 

 Router(config)#ip nat inside source static 172.16.1.3 200.1.1.1       

                  (建立两个IP之间的静态映射)

 Router(config)#ip classless

 Router(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.

动态多对一

 

1 定义一个地址池

 Router(config)#ip nat pool dyn-nat 192.16.2.1 192.16.2.254

                   (自定义名)

 Router(config)#netmask 255.255.255.0

2、定义一个访问控制列表

 Router(config)#access-list 1 permit 10.1.1.0 0.0.0.255

3、调用访问控制列表accest-list 1

 Router(config)#ip nat inside source list 1 pool dyn-nat  overload(其关键性词)

4、应用于端口

 Router(config)#interface ethernet0

 Router(config-router)#ip add 10.1.1.1 255.255.255.0

 Router(config-router)#in nat inside

 

 Router(config)#interface serial

 Router(config-router)#ip address 192.16.2.1 255.255.255.0

 Router(config-router)#ip nat outside

 

 

 

校园网模拟配置

switch A 2950

 swA(config)#vlan 11

 swA(config)#vlan 12

 swA(config)#vlan 100 name admin

 swA(config)#intface f0/1

 swA(config)#switchport mode access

 swA(config)#switchport access vlan 11

 swA(config)#intface f0/2

 swA(config)#switchport mode access

 swA(config)#switchport access vlan 12

 swA(config)#intface vlan 100

 swA(config)#ip add 192.168.100.2 255.255.255.0

 swA(config)#no shutdown

 swA(config)#ip default-gateway 192.168.100.1

 swA(config)#intface f0/10

 swA(config)#switchport mode trunk

 swA(config)#switchport trunk allowde vlan all

 swA(config)#line vty 0 4

 swA(config)#password cisco

 swA(config)#login

 swA(config)#line console 0

 swA(config)#password cisco

 swA(config)#enable secret cisco

 swA(config)#service password-encryption

 

switchB楼:(2950

 swB(config)#vlan 21

 swB(config)#vlan 22

 swB(config)#vlan 100 name admin

 swB(config)#intface f0/1

 swB(config)#switchport mode access

 swB(config)#switchport access vlan 21

 swB(config)#intface f0/2

 swB(config)#switchport mode access

 swB(config)#switchport access vlan 22

 swB(config)#intface vlan 100

 swB(config)#ip add 192.168.100.3 255.255.255.0

 swB(config)#no shutdown

 swB(config)#ip default-gateway 192.168.100.1

 swB(config)#intface f0/10

 swB(config)#switchport mode trunk

 swB(config)#switchport trunk allowde vlan all

 swB(config)#line vty 0 4

 swB(config)#password cisco

 swB(config)#login

 swB(config)#line console 0

 swB(config)#password cisco

 swB(config)#enable secret cisco

 swB(config)#service password-encryption

三层交换机:(3750

 switch(config)#vlan 11

 switch(config)#vlan 12

 switch(config)#vlan 21

 switch(config)#vlan 22

 switch(config)#vlan 100 name admin

 switch(cofnig)#intface vlan 11

 switch(cofnig)#ip add 192.168.11.1 255.255.255.0

 switch(config)#intface vlan 12

 switch(config)#ip add 192.168.12.1 255.255.255.0

 switch(config)#intface vlan 21

 switch(cofnig)#ip add 192.168.21.1 255.255.255.0

 switch(config)#intface vlan 22

 switch(cofnig)#ip add 192.168.22.1 255.255.255.0

 switch(config)#intface vlan 100

 switch(config)#ip 192.168.100.1 255.255.255.0

 switch(config)#intface f1/0/1

 switch(config)#switchport trunk encapsulation dot1Q

 switch(config)#switchport mode trunk

 switch(config)#switchport trunk allowed vlan all

 switch(config)#intface f1/0/2

 switch(config)#switchport trunk encapsulation dot1Q

 switch(config)#switchport mode trunk

 switch(config)#switchport trunk allowed vlan all

 switch(config)#intface f1/0/10

 switch(config)#no switchport

 switch(config)#ip add 192.168.200.1 255.255.255.0

 switch(config)#no shut

 switch(config)#ip routting

 switch(config)#line vty 0 4

 switch(config)#password cisco

 switch(config)#login

 switch(config)#line console 0

 switch(config)#password cisco

 switch(config)#enable secret cisco

 switch(config)#service password-encryption

 switch(config)#service dhcp

 switch(config)#dchp ip-pool cisco

 switch(cofnig)#network 192.168.11.0 255.255.255.0

 switch(config)#dns-server 202.102.192.68

 switch(config)#default-route 192.168.11.1

 switch(config)#ip dhcp excluded-address 192.168.11.1

 switch(config)#service dhcp

 switch(config)#dchp ip-pool cisco

 switch(cofnig)#network 192.168.12.0 255.255.255.0

 switch(config)#dns-server 202.102.192.68

 switch(config)#default-route 192.168.12.1

 switch(config)#ip dhcp excluded-address 192.168.12.1

 switch(config)#service dhcp

 switch(config)#dchp ip-pool cisco

 switch(cofnig)#network 192.168.21.0 255.255.255.0

 switch(config)#dns-server 202.102.192.68

 switch(config)#default-route 192.168.21.1

 switch(config)#ip dhcp excluded-address 192.168.21.1

 switch(config)#service dhcp

 switch(config)#dchp ip-pool cisco

 switch(cofnig)#network 192.168.22.0 255.255.255.0

 switch(config)#dns-server 202.102.192.68

 switch(config)#default-route 192.168.22.1

 switch(config)#ip dhcp excluded-address 192.168.22.1

 access-list 150 deny   udp any any eq tftp

 access-list 150 deny   tcp any any eq 135

 access-list 150 deny   udp any any eq 135

 access-list 150 deny   udp any any eq netbios-ns

 access-list 150 deny   udp any any eq netbios-dgm

 access-list 150 deny   tcp any any eq 139

 access-list 150 deny   udp any any eq netbios-ss

 access-list 150 deny   tcp any any eq 445

 access-list 150 deny   udp any any eq 445

 access-list 150 deny   udp any any eq 539

 access-list 150 deny   tcp any any eq 539

 access-list 150 deny   tcp any any eq 593

 access-list 150 deny   udp any any eq 593

 access-list 150 deny   udp any any eq 1434

 access-list 150 deny   tcp any any eq 4444

 access-list 150 permit icmp any any echo

 access-list 150 permit icmp any any echo-reply

 access-list 150 permit icmp any any 11 0

 access-list 150 permit icmp any any host-unreachable

 access-list 150 permit icmp any any net-unreachable

 access-list 150 permit icmp any any port-unreachable

 access-list 150 deny   icmp any any

 access-list 150 permit ip any any

 

总部路由(cisco 1841

 router(config)#intface f0/0

 router(config-route)#ip add 192.168.200.2 255.255.255.0

 router(config-route)#no shutdown

 router(config-route)#ip nat inside

 router(config)#interface f0/1

 router(config-route)#ip add 218.22.50.20 255.255.255.254

 router(config-route)#description this is link-to-internet

 router(config-route)#ip nat outside

 router(config)#ip nat inside source list 1 interface f0/1 overload

 router(config)#access-list 1 permit 192.168.0.0 0.0.255.255

 router(cofnig)#ip route 0.0.0.0 0.0.0.0 218.22.50.17

 router(cofnig)#ip route 192.168.0.0 0.0.255.255 192.168.200.2

 router(config)#line vty 0 4

 router(config)#password cisco

 router(config)#login

 router(config)#line console

 router(config)#password cisco

 router(config)#login

 router(config)#

 router(config)#enable secret cisco

 router(config)#service password-encryption

本文转载自:http://blog.sina.com.cn/s/blog_62e301bd0100hgvy.html

SANSOM
粉丝 48
博文 384
码字总数 287953
作品 0
徐汇
其他
私信 提问
cisco配置命令

Cisco路由器应该是目前路由市场中需求量很多的品牌之一,下面就以Cisco路由为例,介绍一下关于Cisco路由器配置命令与交换机配置命令,从配置命令上看,分析出路由器和交换机之间的区别。 1....

shen2099201
2013/06/03
0
0
通过IP查找交换机端口(CISCO)

一、简介 在一个Cisco 交换网络中间,已知某台机器的IP地址,如何找出它连接到了哪台交换机的哪个端口上呢?本章将实验演示。 很基础的查找命令,但是有时候很多人都会忘记,当然,对新手除外...

风过_无痕
2017/08/24
0
0
经典案例:H3C校园网双出口配置

博主QQ:819594300 博客地址:http://zpf666.blog.51cto.com/ 有什么疑问的朋友可以联系博主,博主会帮你们解答,谢谢支持! 一、案例分析 本案例以某高校的校园网出口为例,来展示NAT及策略...

Mr大表哥
2018/06/28
0
0
网络工程师软件solarwinds tools功能介绍

SolarWinds Engineer’s Edition包括以下工具: 1. 网络性能监控(Network Performance Monitoring):带宽测量(Bandwidth Gauges )、路由CPU负荷(Router CPU Load)、带宽监控(Bandwid...

羊草
2018/01/31
0
0
三层交换(VLAN间互通+路由功能)+VTP+STP(PVST)综合实验(理论+实践=真实)

三层交换(VLAN间互通+路由功能)+VTP+STP(PVST) 综合实验(理论+实践=经验) 【需求分析】 本实验采用双核心结构,将三层交换技术和VTP、STP、以太网通道综合一起,实现网络的高速、高性能、高...

日久不生情
2017/11/24
0
0

没有更多内容

加载失败,请刷新页面

加载更多

JVM -- Java堆结构及对象分代

Hello,今天记录下 Java虚拟机中的其中一个重点知识 --> Java堆。 一起学习,一起进步。继续沉淀,慢慢强大。希望这文章对您有帮助。若有写的不好的地方,欢迎评论给建议哈! 初写博客不久,...

猫狗熊
2分钟前
1
0
elastic-job的使用

概述: 公司用了elastic-job来执行定时任务和管理定时任务,所以最近研究了一下写了个demo,由于我是把zookeeper部署在了docker上的,所以这里简单介绍下docke的基础命令。 1、Docker基础命令...

你个小机灵鬼
3分钟前
1
0
Cadence Allegro 中skill应用教程:让代码替我们打工

SKILL语言是Candence提供给用户的一个开发接口,利用其本身提供的接口函数和SKILL语言完成自动化操作的功能。 怎么查看SKILL: 1.可以直接用写字板打开进行编辑或看功能说明。 2.想自己写或改...

demyar
4分钟前
1
0
如何看待技术债务

关于技术债务,做开发的同学对如下场景应该不陌生: 为了敢项目进度,详细设计、单元测试等过程就不写了,以后补 需求变化万千,原本架构设计无法满足新的需求,可是又不想动架构,于是绕过架...

嘿嘿嘿IT
6分钟前
1
0
深入理解 web 协议(一)- http 包体传输

本文首发于 vivo互联网技术 微信公众号 链接:https://mp.weixin.qq.com/s/WlT8070LlrnSODFRDwZsUQ 作者:吴越 开坑这个系列的原因,主要是在大前端学习的过程中遇到了不少跟web协议有关的问...

vivo互联网技术
6分钟前
1
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部