文档章节

关于This version of the rendering library is more recent than your version of ADT plug-in.解决方案

tyronejw
 tyronejw
发布于 2015/05/18 11:00
字数 271
阅读 559
收藏 0


预览layout.xml文件时提示:

This version of the rendering library is more recent than your version of ADT plug-in. Please update ADT plug-in

导致无法正常预览布局文件;

问题根源:SDK版本过高,ADT版本低;

解决办法有好几种,如下:

1.

  1. Click Help > Install New Software.

  2. In the Work with field, enter: https://dl-ssl.google.com/android/eclipse/

  3. Select Developer Tools / Android Development Tools.

  4. Click Next and complete the wizard.

2.

Change android version while rendering layout.

3,

Change the Target version to new updates you have. Otherwise, change what SDK version you have in the Android manifest file.

android:minSdkVersion="8"
android:targetSdkVersion="18"

预览layout.xml文件时提示:

This version of the rendering library is more recent than your version of ADT plug-in. Please update ADT plug-in

导致无法正常预览布局文件;

问题根源:SDK版本过高,ADT版本低;

解决办法有好几种,如下:

1.

  1. Click Help > Install New Software.

  2. In the Work with field, enter: https://dl-ssl.google.com/android/eclipse/

  3. Select Developer Tools / Android Development Tools.

  4. Click Next and complete the wizard.

2.

Change android version while rendering layout.

3,

Change the Target version to new updates you have. Otherwise, change what SDK version you have in the Android manifest file.

android:minSdkVersion="8"
android:targetSdkVersion="18"

本文转载自:http://blog.csdn.net/g19920917/article/details/20289247

tyronejw
粉丝 3
博文 126
码字总数 20540
作品 0
深圳
私信 提问
This version of the rendering library is more ....

地址:http://stackoverflow.com/questions/18852983/eclipse-reports-rendering-library-more-recent-than-adt-plug-in This version of the rendering library is more recent than your v......

感觉太煽情
2015/09/01
572
0
解决Eclipse更新ADT插件时遇到的Eclipse reports rendering library more recent than ADT plug-in问题

使用 SDK Manager 工具更新下载新版本后,无法显示可视化布局,同时提示 This version of the rendering library is more recent than your version of ADT plug-in. Please update ADT plu......

xiaopangzi520
2018/06/26
0
0
eclipse创建android项目无法正常预览布局文件

eclipse创建android项目时,预览layout.xml文件时提示: This version of the rendering library is more recent than your version of ADT plug-in. Please update ADT plug-in,导致无法正......

独钓渔
2015/03/19
5.7K
0
创建第一个Android程序 HelloWorld

直接上图: -----------------------------------华丽的分割线----------------------------------------------- 完成之后,如果预览layout.xml文件时提示: This version of the rendering ......

40岁的青春
2015/04/10
69
0
Android布局文件不显示预览效果

最近使用 Help --> Check for Updates 升级了Eclipse部分插件,之后新建4.3的工程,res/layout 下的xml布局文件无法预览了, 一预览总是报这个错: This version of the rendering library ...

Java编程思想
2013/11/02
1K
0

没有更多内容

加载失败,请刷新页面

加载更多

nginx学习笔记

中间件位于客户机/ 服务器的操作系统之上,管理计算机资源和网络通讯。 是连接两个独立应用程序或独立系统的软件。 web请求通过中间件可以直接调用操作系统,也可以经过中间件把请求分发到多...

码农实战
今天
5
0
Spring Security 实战干货:玩转自定义登录

1. 前言 前面的关于 Spring Security 相关的文章只是一个预热。为了接下来更好的实战,如果你错过了请从 Spring Security 实战系列 开始。安全访问的第一步就是认证(Authentication),认证...

码农小胖哥
今天
11
0
JAVA 实现雪花算法生成唯一订单号工具类

import lombok.SneakyThrows;import lombok.extern.slf4j.Slf4j;import java.util.Calendar;/** * Default distributed primary key generator. * * <p> * Use snowflake......

huangkejie
昨天
12
0
PhotoShop 色调:RGB/CMYK 颜色模式

一·、 RGB : 三原色:红绿蓝 1.通道:通道中的红绿蓝通道分别对应的是红绿蓝三种原色(RGB)的显示范围 1.差值模式能模拟三种原色叠加之后的效果 2.添加-颜色曲线:调整图像RGB颜色----R色增强...

东方墨天
昨天
11
1
将博客搬至CSDN

将博客搬至CSDN

算法与编程之美
昨天
13
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部