CDH应用之各类疑难杂症

原创
2017/01/10 17:23
阅读数 162
  • impala-shell无法使用,报coordinator无法连接

按照网上的做法,试图用service impala-server restart来重新启动服务,结果提示service不存在。

最后还是用cloudera manager来重新启动impala服务解决的。

  • 创建一个新用户之后,执行hadoop命令,都提示Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/hadoop/fs/FsShell : Unsupported major.minor version 51.0

实际原因是java版本不对,系统里有多个java版本,新用户使用了低版本,如jdk1.6。 解决的办法很简单,要么修改path,让jdk1.7的path出现在最前面,要么修改系统默认java命令的指向。 例如: mac@BBXX-129-40-246:/usr/java> ls -l total 8 lrwxrwxrwx 1 root root 16 Feb 13 14:36 default -> /usr/java/latest drwxr-xr-x 9 root root 4096 Feb 13 14:36 jdk1.6.0_31 drwxr-xr-x 8 root root 4096 Feb 17 14:37 jdk1.7.0_67-cloudera lrwxrwxrwx 1 root root 30 Feb 17 14:38 latest -> /usr/java/jdk1.7.0_67-cloudera

只要把latest执行jdk1.7就可以了。 ln -s jdk1.7.0_67-cloudera latest

  • 执行beeline,连接cdh 5.10版本的hive server时,提示 Required field 'client_protocol' is unset!

这个原因就是beeline的版本和cdh hive server的版本不匹配。换了一台cdh5.10的节点机,再用beeline连,就没有问题了。

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部