Ubuntu升级到12.04后Subclipse报Failed to load JavaHL Library错误的解决方法
Ubuntu升级到12.04后Subclipse报Failed to load JavaHL Library错误的解决方法
猪刚烈 发表于3年前
Ubuntu升级到12.04后Subclipse报Failed to load JavaHL Library错误的解决方法
  • 发表于 3年前
  • 阅读 4
  • 收藏 0
  • 点赞 0
  • 评论 0

腾讯云 技术升级10大核心产品年终让利>>>   

Ubuntu升级到12.04后,Subclipse不能正常工作,打开后报错:

Failed to load JavaHL Library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path = /usr/lib/jni

看来是原来指定 的JavaHL的路径失效了。能过命令:

sudo find /usr -name libsvnjavahl-1.so

查找其中的缺失文件,发现在文件位于:

/usr/lib/x86_64-linux-gnu/jni/libsvnjavahl-1.so

说明Ubuntu升级到12.04以后,JavaHL Library的位置由原来/usr/lib/jni改为了/usr/lib/x86_64-linux-gnu/jni

所以解决方法就是打开eclipse安装目录下的eclipse.ini文件,将原来配置的

-Djava.library.path=/usr/lib/jni

改为

-Djava.library.path=/usr/lib/x86_64-linux-gnu/jni

即可

共有 人打赏支持
粉丝 22
博文 708
码字总数 110
作品 1
×
猪刚烈
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: