文档章节

PHP version manager

wild-life
 wild-life
发布于 2015/04/01 12:39
字数 262
阅读 25
收藏 0

git主页:https://github.com/phpbrew/phpbrew

依赖环境:https://github.com/phpbrew/phpbrew/wiki/Requirement

使用时报错查看:

[root@slave2 ~]# tail -F /root/.phpbrew/build/php-5.5.22/build.log
开始安装:
[root@slave2 ~]# phpbrew install 5.5.22                            
===> phpbrew will now build 5.5.22
You haven't set any variant. A default set of extensions will be installed for the minimum requirement:
[bcmath, bz2, calendar, cli, ctype, dom, fileinfo, filter, ipc, json, mbregex, mbstring, mhash, pcntl, pcre, pdo, phar, posix, readline, sockets, tokenizer, xml, curl, zip, openssl]
Please run 'phpbrew variants' for more information.
===> Loading and resolving variants...
Checking distribution checksum...
Checksum matched: cd5a6321d71897dec26e29e795926669
===> Distribution file was successfully extracted, skipping...
Found existing build.log, renaming it to /root/.phpbrew/build/php-5.5.22/build.log.1427854142
===> Configuring 5.5.22...
Use tail command to see what's going on:
   $ tail -F /root/.phpbrew/build/php-5.5.22/build.log
===> Building...
Build finished: 4.4 minutes.
Installing...
---> Creating php-fpm.conf
---> Creating php.ini
---> Copying /root/.phpbrew/build/php-5.5.22/php.ini-development 
---> Found date.timezone is not set, patching...
Initializing pear config...
sh: pear: command not found
sh: pear: command not found
sh: pear: command not found
Enabling pear auto-discover...
sh: pear: command not found
Congratulations! Now you have PHP with 5.5.22 as php-5.5.22
To use the newly built PHP, try the line(s) below:
    $ phpbrew use php-5.5.22
Or you can use switch command to switch your default php to php-5.5.22:
    $ phpbrew switch php-5.5.22
Enjoy!

卸载:

phpbrew remove php-5.5.22


© 著作权归作者所有

wild-life
粉丝 17
博文 94
码字总数 56147
作品 0
成都
技术主管
私信 提问
Windows 2008 IIS同时配置多版本的php

Windows可以通过IIS下安装PHP Manager工具让IIS可以同时支持多版本的php,具体步骤如下: 1.下载PHP Manager软件(可以在http://phpmanager.codeplex.com/releases/view/69115下载),下载后...

星痕2018
2015/11/17
0
0
如何在Windows7(IIS7)环境下安装 PHP

IIS7:可能需要用到 Windows 系统安装光盘 PHP Manager:访问 http://phpmanager.codeplex.com/releases/view/69115 下载 PHP:访问 http://windows.php.net 下载 打开(1)[程序和功能],然后...

梦梦阁
2015/10/31
0
0
IIS7(Windows7)下最简单最强安装多版本PHP支持环境

最近调试程序,要在PHP5.2和5.3之间换来换去,而习惯了windows下的开发,就琢磨怎么在iis下安装多版本支持,赫然发现其实微软都为我们准备了好工具。 微软对PHP的支持越来越强,这点在IIS7中...

as007012012
2017/03/02
0
0
Windows 7 上 IIS 和 Apache 性能测试对比

环境(64位Win7): IIS7+PHP5.4(NTS非线程安全版本) vs Apache2.4(32位)+PHP5.4 静态文件处理: ab -k -c100 -n10000 http://127.0.0.1/info.htm # IIS RPS 1709 ab -k -c100 -n10000 http://1......

eechen
2015/04/15
0
4
phpmanager一步配置php环境

打开IIS7进行PHP Manager进行配置 第四、单击“Register new PHP version”,弹出框中浏览选择“php-cgi.exe” 前提是需要在磁盘上保存有PHP相关文件http://www.php.net/downloads.php...

狂沙lover
2013/01/15
0
0

没有更多内容

加载失败,请刷新页面

加载更多

Mac部分目录读写提示“Operation not permitted”解决

今天试图在mac os x下重命名/usr/bin/python,提示Operation not permitted,虽然我是root,很奇怪。原来mac os x里还有一个安全机制:rootless,少用root。参考这篇文章如何开关rootless,不...

swingcoder
32分钟前
2
0
49.Nginx防盗链 访问控制 解析php相关 代理服务器

12.13 Nginx防盗链 12.14 Nginx访问控制 12.15 Nginx解析php相关配置(502的问题) 12.16 Nginx代理 扩展 502问题汇总 http://ask.apelearn.com/question/9109 location优先级 http://blog....

oschina130111
38分钟前
4
0
信必优成功案例 – 中国网络电视台(CNTV)

项目背景 •中国网络电视台(英文简称CNTV),由央视国际网络有限公司主办,是中央电视台旗下的国家网络广播电视播出机构。中国网络电视台全面部署多终端业务架构,已建设网络电视、IP电视、...

symbiochina88
38分钟前
6
0
redis cluster集群 三主三从

redis 集群一般由 多个节点 组成,节点数量至少为 6 个,才能保证组成 完整高可用 的集群。每个节点需要 开启配置 cluster-enabled yes,让 redis 运行在 集群模式 下。 redis5之后使用redis...

MonroeCode
40分钟前
1
0
新东方的Kubernetes实践:从服务化ES到Kafka和Redis

2017年,新东方开始了利用容器化手段将中间件业务服务化的探索,基于Rancher 1.6使用ES;2019年,新东方再次开始了扩大了中间件的业务服务化,基于Kubernetes使用Kafka、ES和Redis。在服务化...

RancherLabs
42分钟前
2
0

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部