OSX Yosemite,pod install报错RPC failed; result=52,

原创
2014/12/23 10:22
阅读数 1.8K

1.  Linux的五个查找命令:find,locate,whereis,which,type 这个你或许会用到,当你的系统里面有多个版本的git的时候,这个可以帮你查看你当前使用的是那个git,这个git在什么位置。

2. git官网这个你也会用得着,从这里下载最新版本的git,我当前装的是2.2.1,如果这里没办法下载,你可以去这里 下载。下载完毕以后,安装这个git。

3. 安装完毕,你去commad line查看,发现你的git版本没有更新,那么怎么才能让系统使用刚安装的这个最新版本的git而不是其他的版本的呢?

4. 在commad line执行下面的代码。让你的系统默认查找/usr/local/git/bin这个目录。

export PATH="/usr/local/git/bin:/usr/local/sbin:~/bin:$PATH"' >> ~/.bash_profile

5. 执行git --version,你会发现已经是最新的git了。

6. 参考链接:http://stackoverflow.com/questions/8957862/how-to-upgrade-git-to-latest-version-on-mac-os-x/8963503#8963503

鄙人遇到的就是这么个问题,如果有其他的问题,欢迎一起讨论。

同时还遇到了brew update 失败的情况,

unable to access 'https://github.com/Homebrew/homebrew/': SSLRead() return error -36

加一个环境变量就好了, GIT_SSL_CAINFO=/path/to/ca-bundle.crt



展开阅读全文
打赏
0
1 收藏
分享
加载中
niu
2016/08/05 15:05
回复
举报
79
2015/07/06 11:13
回复
举报
更多评论
打赏
2 评论
1 收藏
0
分享
返回顶部
顶部