文档章节

CentOS下LAMP一键yum安装脚本

lwaif
 lwaif
发布于 2017/06/05 11:47
字数 498
阅读 44
收藏 0

本脚本适用环境:

  • 系统支持:CentOS/Redhat/Fedora
  • 内存要求:≥64M
  • 硬盘要求:2GB以上的剩余空间
  • 服务器必须配置好软件源和可连接外网
  • 必须具有系统 root 权限
  • 建议使用干净系统全新安装

关于本脚本:

  • 一键 yum 安装所有的软件包,方便升级;
  • 支持 PHP 自带所有组件;
  • 支持 MySQL ,MariaDB 数据库;
  • 支持 XCache ;
  • 支持 Zend Guard Loader ;
  • 支持 ionCube PHP Loader ;
  • 支持自助升级 phpMyAdmin;
  • 命令行新增虚拟主机,操作简便;
  • 一键卸载(卸载前请注意备份数据)。

将会安装:

  • 1、Apache
  • 2、MySQL 5.5 latest version 或 MariaDB 5.5 latest version(二选一)
  • 3、PHP 5.4 latest version
  • 4、phpMyAdmin latest version
  • 5、xcache
  • 6、ZendGuardLoader
  • 7、ionCube PHP Loader

如何安装:
第一步,下载、解压、赋予执行权限:

wget --no-check-certificate https://github.com/teddysun/lamp-yum/archive/master.zip -O lamp-yum.zip
unzip lamp-yum.zip
cd lamp-yum-master/
chmod +x *.sh

第二步,安装LAMP一键安装包
终端中输入以下命令:

./lamp.sh 2>&1 | tee lamp.log

使用提示:
lamp add(del,list):创建(删除,列出)虚拟主机。
lamp uninstall:一键删除 LAMP(切记,删除之前注意备份好数据!)

程序目录:
MySQL 或 MariaDB 数据库目录: /var/lib/mysql
默认的网站根目录: /data/www/default

命令一览:
MySQL 或 MariaDB 命令:

/etc/init.d/mysqld(start|stop|restart|reload|status)
service mysqld(start|stop|restart|reload|status)

Apache命令:

/etc/init.d/httpd(start|stop|restart|reload|status)
service httpd(start|stop|restart|reload|status)

更多信息或下载安装包请参考项目主页:https://github.com/teddysun/lamp-yum

关于本脚本的说明:
1、Apache 为系统默认的版本,MySQL ,MariaDB 和 PHP 则是 Atomic repository 的最新版。
2、如果你的 VPS 内存≥256M,建议编译安装 LAMP,详见:这里
3、升级 phpMyAdmin 命令:./update_phpmyadmin.sh

更新日志:

更新(2014年06月25日): 新增 MariaDB 安装选项;新增升级 phpMyAdmin 的一键脚本 update_phpmyadmin.sh。
更新(2014年06月10日): 通过 yum 安装 LAMP 生产环境一键安装包,初版作成。

本文转载自:

共有 人打赏支持
lwaif
粉丝 6
博文 142
码字总数 19347
作品 0
深圳
私信 提问
wdlinux lanmp一键安装包

wdlinux lanmp一键安装包 [我的Linux,让Linux更易用]此安装包为web环境的lamp 或 lnmp 安装,除在mysql设置密码时会有提示操作,其它均为自动直到安装完成.简单,方便,快速 包括 lamp (apache +...

wdlinuxcn
2010/09/17
0
0
一键安装包 lanmp_v3.1 版本发布

lanmp一键安装包是集成了lamp,lnmp,lnamp三种模式的开源软件WEB应用部署安装软件包,能方便快速部署WEB应用环境lanmp一键安装包是wdlinux官网2010年底开始推出的web应用环境的快速简易安装包...

wdlinuxcn
2016/05/12
753
1
lnmp、lamp、lnmpa一键安装包

(Updated: 2016-8-21) 这个脚本是使用shell编写,为了快速在生产环境上部署lnmp/lamp/lnmpa(Linux、Nginx/Tengine/OpenResty、MySQL/MariaDB/Percona、PHP),适用于CentOS 5~7(包括red...

Yomut
2016/09/30
71
0
RHEL7配置LAMP环境+ Zabbix安装

首先更新YUM源,一键安装包依赖yum。 RHEL7 未注册不能使用yum,所以修改使用Centos7的yum http://blog.csdn.net/yudar1024/article/details/42298477 要把$releasever改成redhat版本号 也就...

张悟空
2016/05/06
127
0
【目录】 Linux技术玩家 持续更新

[编辑器相关] Windows下用notepad++ 打造Linux 代码编辑环境 送给不使用vim的Linux Guy http://990487026.blog.51cto.com/10133282/1844735 ubuntu 源码编译安装最新的vim 8.0 http://990487...

990487026
2016/09/01
0
0

没有更多内容

加载失败,请刷新页面

加载更多

Ubuntu16.04下安装docker

[TOC] 本文开发环境为Ubuntu 16.04 LTS 64位系统,通过apt的docker官方源安装最新的Docker CE(Community Edition),即Docker社区版,是开发人员和小型团队的理想选择。 1. 开始安装 1.1 由于...

豫华商
今天
10
0
使用XShell工具密钥认证登录Linux系统

如果你是一名Linux运维,那么Linux服务器的系统安全问题,可能是你要考虑的,而系统登录方式有两种,密码和密钥。哪一种更加安全呢? 无疑是后者! 这里我为大家分享用Xshell利器使用密钥的方...

dragon_tech
今天
7
0
day178-2018-12-15-英语流利阅读-待学习

“真蛛奶茶”了解一下?蜘蛛也会产奶了 Lala 2018-12-15 1.今日导读 “蛋白质含量是牛奶的 4 倍,并有着更低的脂肪和含糖量”,听起来诱人又美味的并不是羊奶或豆奶,而是你可能打死都想不到...

飞鱼说编程
今天
12
0
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents

场景重现 npm install --verbose 安装依赖的时,出现如下警告 强迫症患者表示不能接受 npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\fsevents):npm WARN......

taadis
今天
2
0
OSChina 周六乱弹 —— 你一口我一口多咬一口是小狗

Osc乱弹歌单(2018)请戳(这里) 【今日歌曲】 @达尔文 :分享Roy Orbison的单曲《She's a Mystery to Me》 《She's a Mystery to Me》- Roy Orbison 手机党少年们想听歌,请使劲儿戳(这里...

小小编辑
今天
464
6

没有更多内容

加载失败,请刷新页面

加载更多

返回顶部
顶部