Centos7 下安装 rabbitMQ

原创
04/29 17:17
阅读数 42

1、版本对应问题

如果你想安装 rabbitmq 的话,那么你就得知道,rabbitmq 是依赖与 erlang 语言的,而且,很操蛋的是,他们之间存在着版本对应的关系,而且,国外的网站都被墙掉了(网速垃圾的一批),加之 linux 系统玩得并不是很溜,就导致这玩意玩起来异常的困难。

mark

点进去之后就是那个版本对应的 github 的地址了,里面有对应的 erlang 版本的介绍地址

mark


2、下载

rabbit

rabbitmq 的下载地址 https://www.rabbitmq.com/download.html

mark

mark

erlang

点击第二个链接:https://github.com/rabbitmq/erlang-rpm/releases

mark

mark

3、安装

将下载下来的两个 rpm 上传到自己的阿里云服务器上去,然后使用 rpm 命令进行安装

rpm -ivh erlang-22.3.3-1.el7.x86_64.rpm
yum install -y socat
rpm -ivh rabbitmq-server-3.8.3-1.el7.noarch.rpm

都安装完成后安装 rabbit 的客户端(端口是15672)

[root@iZ2zegodyh41n91kyexa9yZ src]# rabbitmq-plugins enable rabbitmq_management
Enabling plugins on node rabbit@iZ2zegodyh41n91kyexa9yZ:
rabbitmq_management
The following plugins have been configured:
  rabbitmq_management
  rabbitmq_management_agent
  rabbitmq_web_dispatch
Applying plugin configuration to rabbit@iZ2zegodyh41n91kyexa9yZ...
The following plugins have been enabled:
  rabbitmq_management
  rabbitmq_management_agent
  rabbitmq_web_dispatch

set 3 plugins.
Offline change; changes will take effect at broker restart.

启动rabbitmq 

sysstemctl start rabbitmq-server

 

 

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
返回顶部
顶部