redhat6安装oracle时需要pdksh、compat-libstdc++组件
博客专区 > imlqh 的博客 > 博客详情
redhat6安装oracle时需要pdksh、compat-libstdc++组件
imlqh 发表于2年前
redhat6安装oracle时需要pdksh、compat-libstdc++组件
  • 发表于 2年前
  • 阅读 37
  • 收藏 0
  • 点赞 0
  • 评论 0

标题:腾讯云 新注册用户域名抢购1元起>>>   

系统:centos6.6


一、 安装盘里没有compat-libstdc++,需要从以下下载。

http://pkgs.org/centos-6/centos-x86_64/compat-libstdc++-33-3.2.3-69.el6.x86_64.rpm/download/


二、 以下是pdksh步骤。

安装时需要注意:从Red Hat Enterprise Linux 6开始,默认只安装主架构所需要的包,而不安装兼容架构的包,也就是说,64位系统默认只安装64位的软件包。为避免这种问题,在64位系统中,要同时安装64位的包和32位的兼容包。

  1. 报错

# rpm -ivh pdksh-5.2.14-1.i386.rpm 

error: Failed dependencies:

ld-linux.so.2 is needed by pdksh-5.2.14-1.i386

libc.so.6 is needed by pdksh-5.2.14-1.i386

libc.so.6(GLIBC_2.0) is needed by pdksh-5.2.14-1.i386

libc.so.6(GLIBC_2.1) is needed by pdksh-5.2.14-1.i386


2. 安装glibc报错

# yum install glibc

Loaded plugins: product-id, refresh-packagekit, security, subscription-manager

This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.

Setting up Install Process

Package glibc-2.12-1.149.el6.x86_64 already installed and latest version

Nothing to do


3. 安装glibc.i686

# yum install glibc.i686

Installed:

  glibc.i686 0:2.12-1.149.el6                                                                                                                              

Dependency Installed:

  nss-softokn-freebl.i686 0:3.14.3-17.el6                                                                                                                  

Complete!


4. 安装pdksh

# rpm -ivh pdksh-5.2.14-1.i386.rpm 

Preparing...                ########################################### [100%]

   1:pdksh                  ########################################### [100%]


共有 人打赏支持
粉丝 1
博文 7
码字总数 1173
×
imlqh
如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!
* 金额(元)
¥1 ¥5 ¥10 ¥20 其他金额
打赏人
留言
* 支付类型
微信扫码支付
打赏金额:
已支付成功
打赏金额: