Idea Usage of API documented as @since 1.4

原创
2019/02/15 15:58
阅读数 49

这个错误的产生原因是代码中使用了@since 1.4, 标记代码只能在jdk 1.4 之后的版本中才能使用,但是项目的编译环境在 1.4 之前,所以idea 给出了这个错误提示。

修复方式:

打开路径

File -> Project Structure -> Project Settings -> Modules -> "Your Module Name" -> Sources -> Language Level

或者直接按快捷键 ctrl-shift-alt s 进入到 Project Structure

选择与使用的jdk 对应的版本就可以了。

展开阅读全文
打赏
0
0 收藏
分享
加载中
更多评论
打赏
0 评论
0 收藏
0
分享
OSCHINA
登录后可查看更多优质内容
返回顶部
顶部