引用 android-support-v4.jar 时候冲突问题解决

原创
2014/10/09 16:08
阅读数 1.5W

引用 android-support-v4.jar 时候冲突问题解决


在开发应用的时候,难以避免的会用到很多第三方的开源项目,这些项目中都会使用android-support-v4.jar包,而我的项目也使用它。

再加上这些开源项目之间还存在各种复杂的引用关系。

就这样引用来、引用去,就可能会出现android-support-v4.jar的冲突问题,类似于:

Jar mismatch! Fix your dependencies

Found 2 versions of android-support-v4.jar in the dependency list,but not all the versions are identical

我的解决方法是:

新建一个空的工程,里面仅仅在libs/下放置一个版本正确的android-support-v4.jar包。

删除你的项目,以及你引用项目中的所有android-support-v4.jar。

为每一个需要用到android-support-v4.jar的工程,增加对步骤1中创建的空工程的依赖。 Properties > Android> Library box > Add

这样以来,可以保证整个工程中用到的v4.jar是单例的。

展开阅读全文
打赏
0
8 收藏
分享
加载中
其实也就是统一一个jar包,问题解决,多谢
2015/01/31 21:03
回复
举报
更多评论
打赏
1 评论
8 收藏
0
分享
返回顶部
顶部