文档章节

Qt: can't find -lGL(Ubuntu16.04)

lieefu
 lieefu
发布于 2016/05/15 14:07
字数 30
阅读 58
收藏 0
点赞 2
评论 0

Qt Creator 4.0
Based on Qt 5.6.0 (64 bit)
Ubuntu 16.04

解决办法:sudo apt-get install libgl1-mesa-dev

http://stackoverflow.com/questions/18406369/qt-cant-find-lgl-error

 

© 著作权归作者所有

共有 人打赏支持
lieefu
粉丝 87
博文 108
码字总数 23811
作品 3
济南
高级程序员
Ubuntu下安装QT5.4.1

首先是下载QT安装包, 官网提供Online(在线)/Offline(离线), 我下载的是离线安装包,QT5.4.1(自带QT Creator)。 接下来是安装 首先你查看你下载来的.run文件是否有执行权限,也就是是否能够...

jannn ⋅ 2015/06/11 ⋅ 0

ubuntu下Qt cannot find -lGL错误的解决方法

在ubuntu下使用Qt 编译时候遇上了cannot find -lGL错误,使用命令 sudo apt-get install libqt4-dev 可以解决问题

Mogra ⋅ 2013/03/17 ⋅ 0

Deepin系统安装QT5

可以从Deepin应用商店中找到并安装qt creator,然后还需安装gcc。 也可以直接从官网下载安装包进行安装: 1.下载安装包 从qt官网上下载,由于qt5.6和5.7都没有直接提供linux的32位离线安装包...

大道无名 ⋅ 2016/07/26 ⋅ 0

linux下opengl的安装(with qt)

sudo apt-get install build-essential sudo apt-get install libgl1-mesa-dev sudo apt-get install libglu1-mesa-dev sudo apt-get install freeglut3-dev qt的.pro文件添加: LIBS += -l......

leo-H ⋅ 2014/07/25 ⋅ 0

QT内使用OpenCV

一、在新文件夹testqt下建立源代码文件main.cpp 二、在源代码文件目录下执行qmake 三、修改testqt.pro如下 四、编译运行 $ qmake $ make g++ -c -m64 -pipe -O2 -Wall -W -DREENTRANT -DQTNO...

wangxuwei ⋅ 2015/12/22 ⋅ 0

ubuntu16.04卸载qt4安装qt5经过

ubuntu16.04默认安装qt4.8版本。我需要用qt调用libvlc-dev来读取rtsp的视频流,需要安装qt-vlc。但qt-vlc的最新版本只支持qt5。所以我下载了qt-vlc的0.8的版本。然后build,cmake,再make。之...

u010320855 ⋅ 2017/05/11 ⋅ 0

Qt5.7.0编译移植到Linux-Arm-A9

Linux环境下编译Qt5.7.0 我的系统是Ubuntu 16.04编译器是arm-linux-gnueabihf-gcc5.4,在ubuntu16.04中直接安装即可。 编译: 第一步: 下载qt-everywhere-opensource-src-5.7.0.tar.gz,这个...

小果汁儿 ⋅ 2015/07/04 ⋅ 1

解决Qt5 Creator无法切换输入法(fcitx),Ubuntu中不能使用搜狗输入法录入汉字问题

本文档2017年6月1日修正,Ubuntu16.04,Qt5.9.0测试通过 2016年6月8日修正,ubuntu 16.04 Qt5.7.0 以及 Qt5.6.1均测试通过 在Qt5.3之前,我发布过解决办法 解决Qt5 Creator无法切换输入法(f...

lieefu ⋅ 2015/09/12 ⋅ 63

Ubuntu16.04编译Warzone2100

不说别的了,直奔主题,我的环境是Ubuntu16.04 x86_64,GCC5.4.0,automake1.15,bash 4.3.6,qtdefault工具链是Qt5.5.1,还有qt4的工具链Qt4.8.7,都是用apt安装的。 简直是无比的坑,为了编...

水台良月 ⋅ 2016/10/23 ⋅ 0

如何自己编译Qt,为静态编译程序减少依赖方便发布做准备

使用./configure -prefix /opt/Qt-5.6 -gstreamer 1.0 make make install 编译后,qml audio可以播放mp3了,也就是qtmutimedia已经使用 gstreamer 1.0了,但是qml界面只能显示英文,所有中文...

lieefu ⋅ 2016/10/09 ⋅ 0

没有更多内容

加载失败,请刷新页面

加载更多

下一页

JavaScript零基础入门——(八)JavaScript的数组

JavaScript零基础入门——(八)JavaScript的数组 欢迎大家回到我们的JavaScript零基础入门,上一节课我们讲了有关JavaScript正则表达式的相关知识点,便于大家更好的对字符串进行处理。这一...

JandenMa ⋅ 今天 ⋅ 0

sbt网络问题解决方案

转自:http://dblab.xmu.edu.cn/blog/maven-network-problem/ cd ~/.sbt/launchers/0.13.9unzip -q ./sbt-launch.jar 修改 vi sbt/sbt.boot.properties 增加一个oschina库地址: [reposit......

狐狸老侠 ⋅ 今天 ⋅ 0

大数据,必须掌握的10项顶级安全技术

我们看到越来越多的数据泄漏事故、勒索软件和其他类型的网络攻击,这使得安全成为一个热门话题。 去年,企业IT面临的威胁仍然处于非常高的水平,每天都会看到媒体报道大量数据泄漏事故和攻击...

p柯西 ⋅ 今天 ⋅ 0

Linux下安装配置Hadoop2.7.6

前提 安装jdk 下载 wget http://mirrors.hust.edu.cn/apache/hadoop/common/hadoop-2.7.6/hadoop-2.7.6.tar.gz 解压 配置 vim /etc/profile # 配置java环境变量 export JAVA_HOME=/opt/jdk1......

晨猫 ⋅ 今天 ⋅ 0

crontab工具介绍

crontab crontab 是一个用于设置周期性被执行的任务工具。 周期性执行的任务列表称为Cron Table crontab(选项)(参数) -e:编辑该用户的计时器设置; -l:列出该用户的计时器设置; -r:删除该...

Linux学习笔记 ⋅ 今天 ⋅ 0

深入Java多线程——Java内存模型深入(2)

5. final域的内存语义 5.1 final域的重排序规则 1.对于final域,编译器和处理器要遵守两个重排序规则: (1)在构造函数内对一个final域的写入,与随后把这个被构造对象的引用赋值给一个引用...

江左煤郎 ⋅ 今天 ⋅ 0

面试-正向代理和反向代理

面试-正向代理和反向代理 Nginx 是一个高性能的反向代理服务器,但同时也支持正向代理方式的配置。

秋日芒草 ⋅ 今天 ⋅ 0

Spring 依赖注入(DI)

1、Setter方法注入: 通过设置方法注入依赖。这种方法既简单又常用。 类中定义set()方法: public class HelloWorldOutput{ HelloWorld helloWorld; public void setHelloWorld...

霍淇滨 ⋅ 昨天 ⋅ 0

马氏距离与欧氏距离

马氏距离 马氏距离也可以定义为两个服从同一分布并且其协方差矩阵为Σ的随机变量之间的差异程度。 如果协方差矩阵为单位矩阵,那么马氏距离就简化为欧氏距离,如果协方差矩阵为对角阵,则其也...

漫步当下 ⋅ 昨天 ⋅ 0

聊聊spring cloud的RequestRateLimiterGatewayFilter

序 本文主要研究一下spring cloud的RequestRateLimiterGatewayFilter GatewayAutoConfiguration @Configuration@ConditionalOnProperty(name = "spring.cloud.gateway.enabled", matchIfMi......

go4it ⋅ 昨天 ⋅ 0

没有更多内容

加载失败,请刷新页面

加载更多

下一页

返回顶部
顶部